aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2022-07-21 02:25:42 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2022-07-21 02:25:42 +0300
commit61b9458776c228b16e2019fabfe9f7f0042e2070 (patch)
tree134183b7d80e8d3fc94895b40f948a678441045f /dev-vcs
parentdev-vcs/gitqlient: 1.5.0 version bump (diff)
downloadguru-61b9458776c228b16e2019fabfe9f7f0042e2070.tar.gz
guru-61b9458776c228b16e2019fabfe9f7f0042e2070.tar.bz2
guru-61b9458776c228b16e2019fabfe9f7f0042e2070.zip
dev-vcs/gitqlient: 9999.ebuild update
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/gitqlient/gitqlient-9999.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/dev-vcs/gitqlient/gitqlient-9999.ebuild b/dev-vcs/gitqlient/gitqlient-9999.ebuild
index 0b7f70742..478fc453f 100644
--- a/dev-vcs/gitqlient/gitqlient-9999.ebuild
+++ b/dev-vcs/gitqlient/gitqlient-9999.ebuild
@@ -1,16 +1,14 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit git-r3 qmake-utils xdg
+inherit git-r3 optfeature qmake-utils xdg
MY_PN="GitQlient"
DESCRIPTION="Multi-platform Git client written with Qt"
HOMEPAGE="https://github.com/francescmm/GitQlient"
-
-#EGIT_BRANCH="develop"
EGIT_REPO_URI="https://github.com/francescmm/${MY_PN}.git"
LICENSE="LGPL-2.1"
@@ -20,11 +18,8 @@ DEPEND="
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
- dev-qt/qtwebchannel:5
- dev-qt/qtwebengine:5[widgets]
dev-qt/qtwidgets:5
"
-
RDEPEND="
${DEPEND}
dev-vcs/git
@@ -33,7 +28,6 @@ RDEPEND="
src_prepare() {
default
sed -i -e "/QMAKE_CXXFLAGS/s:-Werror::" "${MY_PN}".pro || die
-
sed -i -e "s:Office:Development:" "${S}/src/resources/${PN}.desktop" || die
}
@@ -44,3 +38,7 @@ src_configure() {
src_install() {
emake INSTALL_ROOT="${D}" install
}
+
+pkg_postinst() {
+ optfeature "Jenkins and/or GitServer plugins support" dev-qt/qtwebchannel:5 dev-qt/qtwebengine:5[widgets]
+}