aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2022-07-21 01:06:13 +0300
committerSergey Torokhov <torokhov-s-a@yandex.ru>2022-07-21 01:06:13 +0300
commit1076bde3bca2d6e6b795b2cb2a2e198a141ed48c (patch)
tree6295f90e8fd8cd10f15378a84b0466e5561fb74d /dev-vcs
parentmedia-video/owncast: Call go using the ego wrapper (diff)
downloadguru-1076bde3bca2d6e6b795b2cb2a2e198a141ed48c.tar.gz
guru-1076bde3bca2d6e6b795b2cb2a2e198a141ed48c.tar.bz2
guru-1076bde3bca2d6e6b795b2cb2a2e198a141ed48c.zip
dev-vcs/lazygit: 0.35 version bump
Test phase is droppped in this ebuild Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/lazygit/Manifest1
-rw-r--r--dev-vcs/lazygit/lazygit-0.35.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-vcs/lazygit/Manifest b/dev-vcs/lazygit/Manifest
index c54446e6b..85bb93e6d 100644
--- a/dev-vcs/lazygit/Manifest
+++ b/dev-vcs/lazygit/Manifest
@@ -1,2 +1,3 @@
DIST lazygit-0.33.tar.gz 3729628 BLAKE2B 1cd9a081e5c0b5bd1248404771ed0d2617ef07ce1257a14ebaa13eab785d70ead908d3151fa6019fbc5149d24f7d69a351e7137c2c3878e38cd0630751197e9d SHA512 e878ef0eb64a8d3fb536767f33787dbf06fd27deb2a292e9658f1c97073b5c30d95f3390215bf973e90acc136bcddb839024fddcd4bf25e6dab5f2762a2db379
DIST lazygit-0.34.tar.gz 3733055 BLAKE2B dd53369181f2abf6d7a4776bc751f39a37eb8184fe3811834ee8a99fdcbd4939b260bd1bb86ed26d54b86f4cd509d065cefddcdc5118c266621dfa697a07e7f8 SHA512 a63dd877220c124282667acaadd2f9c55c47687e0c65caff9f61c5a6a3cecc202501fdbd3a1ee13752c8e68bbbb920b5b198459e71a44c585d594675b931d5c2
+DIST lazygit-0.35.tar.gz 3896489 BLAKE2B 686af67f3f90fe3e4817c4a30396902e170b67b2892f2907f87e401495d0d1437d9dad6a7609d49d59632c1575af60a53f24042b74b25d00c567d2f0c7afdd87 SHA512 0a121399070b75cdb9f64fff238866c54684e5989d38cd95a822cccc7d16de44f08bb01e93c546874f0c39ed8198e78e03f5167bb711fce643f6a137e05438b9
diff --git a/dev-vcs/lazygit/lazygit-0.35.ebuild b/dev-vcs/lazygit/lazygit-0.35.ebuild
new file mode 100644
index 000000000..fe68b4b72
--- /dev/null
+++ b/dev-vcs/lazygit/lazygit-0.35.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Simple terminal UI for git commands"
+HOMEPAGE="https://github.com/jesseduffield/lazygit"
+SRC_URI="https://github.com/jesseduffield/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD ISC MIT Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-vcs/git"
+
+DOCS=( {CODE-OF-CONDUCT,CONTRIBUTING,README}.md docs )
+
+src_compile() {
+ go build -o bin/lazygit || die
+}
+
+src_install() {
+ dobin bin/lazygit
+ einstalldocs
+}