aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-07-24 02:35:21 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-07-24 02:43:25 +0500
commit7e8256c8592a3c2bf5990a89ccd1bcfd9cda021d (patch)
tree04fefd871bd8d3e2c12c621700675f89b4455fd5 /dev-util
parentwww-apps/gotosocial: add 0.10.0 (diff)
downloadguru-7e8256c8592a3c2bf5990a89ccd1bcfd9cda021d.tar.gz
guru-7e8256c8592a3c2bf5990a89ccd1bcfd9cda021d.tar.bz2
guru-7e8256c8592a3c2bf5990a89ccd1bcfd9cda021d.zip
dev-util/upstream-ontologist: switch to single-impl python
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/upstream-ontologist/upstream-ontologist-0.1.35-r1.ebuild (renamed from dev-util/upstream-ontologist/upstream-ontologist-0.1.35.ebuild)26
1 files changed, 16 insertions, 10 deletions
diff --git a/dev-util/upstream-ontologist/upstream-ontologist-0.1.35.ebuild b/dev-util/upstream-ontologist/upstream-ontologist-0.1.35-r1.ebuild
index 621304ac2..f1c64cbf5 100644
--- a/dev-util/upstream-ontologist/upstream-ontologist-0.1.35.ebuild
+++ b/dev-util/upstream-ontologist/upstream-ontologist-0.1.35-r1.ebuild
@@ -3,8 +3,9 @@
EAPI=8
-PYTHON_COMPAT=( python3_10 )
+PYTHON_COMPAT=( python3_{10..11} )
DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_SINGLE_IMPL=1
PYPI_NO_NORMALIZE=1
inherit edo distutils-r1 optfeature pypi
@@ -19,18 +20,22 @@ SLOT="0"
KEYWORDS="~amd64"
RDEPEND="
- dev-python/python-debian[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- dev-vcs/breezy[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/python-debian[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ ')
+ dev-vcs/breezy[${PYTHON_SINGLE_USEDEP}]
"
BDEPEND="
test? (
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/markdown[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ ')
)
"
@@ -48,6 +53,7 @@ python_test() {
src_install() {
distutils-r1_src_install
+
doman man/*
dodoc docs/*
}