aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-08-09 05:08:33 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-08-09 05:08:33 +0500
commit266ce0e3418e9cd7bc656cb898729d41d5e11509 (patch)
tree8c0439c33250701bb860f27650172268faa464e4 /dev-util
parentkde-misc/kio-gemini: add 20240801, drop 20230419 (diff)
downloadguru-266ce0e3418e9cd7bc656cb898729d41d5e11509.tar.gz
guru-266ce0e3418e9cd7bc656cb898729d41d5e11509.tar.bz2
guru-266ce0e3418e9cd7bc656cb898729d41d5e11509.zip
dev-util/lottieconverter: add missing deps
Closes: https://bugs.gentoo.org/932402 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/lottieconverter/lottieconverter-0.2-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/lottieconverter/lottieconverter-0.2-r1.ebuild b/dev-util/lottieconverter/lottieconverter-0.2-r1.ebuild
new file mode 100644
index 0000000000..188924a487
--- /dev/null
+++ b/dev-util/lottieconverter/lottieconverter-0.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Simple lottie (telegram animated sticker) converter"
+HOMEPAGE="https://github.com/sot-tech/LottieConverter"
+SRC_URI="https://github.com/sot-tech/${PN}/archive/refs/tags/r${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/LottieConverter-r${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+DEPEND="
+ media-libs/giflib:=
+ media-libs/libpng:=
+ media-libs/rlottie:=
+ sys-libs/zlib:=
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSYSTEM_PNG=ON
+ -DSYSTEM_RL=ON
+ -DSYSTEM_GL=ON
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ dobin "${BUILD_DIR}"/lottieconverter
+ einstalldocs
+}