aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTakuya Wakazono <pastalian46@gmail.com>2024-06-22 20:17:31 +0900
committerTakuya Wakazono <pastalian46@gmail.com>2024-06-22 20:22:42 +0900
commit626d8e1187b964d7e137d8e9af523d7afddab9a4 (patch)
treed4d5c0058f56fd693f892cb551658cbf7daa9752 /dev-ruby
parentmedia-sound/bespokesynth: new package (diff)
downloadguru-626d8e1187b964d7e137d8e9af523d7afddab9a4.tar.gz
guru-626d8e1187b964d7e137d8e9af523d7afddab9a4.tar.bz2
guru-626d8e1187b964d7e137d8e9af523d7afddab9a4.zip
dev-ruby/asciidoctor-pdf: add 2.3.17
Signed-off-by: Takuya Wakazono <pastalian46@gmail.com>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/asciidoctor-pdf/Manifest1
-rw-r--r--dev-ruby/asciidoctor-pdf/asciidoctor-pdf-2.3.17.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor-pdf/Manifest b/dev-ruby/asciidoctor-pdf/Manifest
index 2a390d67b..4781fe203 100644
--- a/dev-ruby/asciidoctor-pdf/Manifest
+++ b/dev-ruby/asciidoctor-pdf/Manifest
@@ -1 +1,2 @@
DIST asciidoctor-pdf-2.3.15.tar.gz 6560656 BLAKE2B 08c49f3773a5a306524afcdc7efc52fd4f441f66cda4e804003670375c8649de792b4c6fbe1880e017a6ddfc21afa33cbc2f804865d4adad6c976003569edb7d SHA512 106ddb2f41f2d92dc7b116d2f0d5d9cf30886199b1fbb17e6e7ab2c8006515362c950d5ef512b5871d6851c7c0dff56d7cb0931365b3e9b1f825bead6d08e769
+DIST asciidoctor-pdf-2.3.17.tar.gz 6561111 BLAKE2B ed46928cec36924257bc9d4f5604e41aa617c5595ab680c3190d95934932947e51639396e5348bbe01169ab20befe0083173cb004d3c23cb30dedcb245e986e3 SHA512 58334cc82660b6710a24dc170d35958dc9cccb2756aa114463cc7e3692e0cec2fd0ba165e093de2c1daf86690d4f64995c6d8f14e169c7586649e5562121499f
diff --git a/dev-ruby/asciidoctor-pdf/asciidoctor-pdf-2.3.17.ebuild b/dev-ruby/asciidoctor-pdf/asciidoctor-pdf-2.3.17.ebuild
new file mode 100644
index 000000000..14acd9088
--- /dev/null
+++ b/dev-ruby/asciidoctor-pdf/asciidoctor-pdf-2.3.17.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc README.adoc"
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+RUBY_FAKEGEM_GEMSPEC="asciidoctor-pdf.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A native PDF converter for AsciiDoc based on Asciidoctor and Prawn"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor-pdf"
+SRC_URI="https://github.com/asciidoctor/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? ( app-text/poppler )"
+
+# prawn-2.5.0 is not compatible yet
+ruby_add_rdepend "
+ >=dev-ruby/asciidoctor-2.0
+ >=dev-ruby/concurrent-ruby-1.1
+ >=dev-ruby/matrix-0.4
+ ~dev-ruby/prawn-2.4.0
+ >=dev-ruby/prawn-icon-3.0.0
+ >=dev-ruby/prawn-svg-0.34.0
+ >=dev-ruby/prawn-table-0.2.0
+ >=dev-ruby/prawn-templates-0.1.0
+ >=dev-ruby/treetop-1.6.0
+ "
+ruby_add_bdepend "test? (
+ >=dev-ruby/chunky_png-1.4.0
+ >=dev-ruby/coderay-1.1.0
+ >=dev-ruby/pdf-inspector-1.3.0
+)"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+
+ sed -i -e "s:_relative ': './:" ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+}
+
+each_ruby_test() {
+ RSPEC_VERSION=3 ruby-ng_rspec -t ~network -t ~visual spec
+}