aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-11-28 01:06:37 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-11-28 01:19:41 +0500
commitdace9e105e00f6d76feb8f52ab7ef31cf9750954 (patch)
treea6f34ac48d082fff726fa22df85d8bc6b1c9e0be /dev-python
parentdev-python/sphinx-version-warning: disable sphinx for 1.1.2 (diff)
downloadguru-dace9e105e00f6d76feb8f52ab7ef31cf9750954.tar.gz
guru-dace9e105e00f6d76feb8f52ab7ef31cf9750954.tar.bz2
guru-dace9e105e00f6d76feb8f52ab7ef31cf9750954.zip
dev-python/myst-parser: disable test failing on pypy3
Closes: https://bugs.gentoo.org/883185 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/myst-parser/myst-parser-0.18.1.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-python/myst-parser/myst-parser-0.18.1.ebuild b/dev-python/myst-parser/myst-parser-0.18.1.ebuild
index 2dba9480e..8d57c1722 100644
--- a/dev-python/myst-parser/myst-parser-0.18.1.ebuild
+++ b/dev-python/myst-parser/myst-parser-0.18.1.ebuild
@@ -48,6 +48,15 @@ distutils_enable_tests pytest
# dev-python/sphinxext-opengraph \
# dev-python/sphinxext-rediraffe
+python_test() {
+ [[ ${EPYTHON} == "pypy3" ]] &&
+ local EPYTEST_DESELECT=(
+ "tests/test_renderers/test_include_directive.py::test_errors[9-Non-existent path:]"
+ )
+
+ epytest
+}
+
pkg_postinst() {
optfeature "linkify plugin support" dev-python/linkify-it-py
}