aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-12-09 14:47:16 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-12-12 16:22:55 +0500
commitceb9c74e8c35f504028816b1b5ba3e8bf30322bb (patch)
tree0bb6f879c90375dd5b09bf852aced58e14a6ffc1 /dev-python
parentdev-python/pytest-steps: enable py3.11 (diff)
downloadguru-ceb9c74e8c35f504028816b1b5ba3e8bf30322bb.tar.gz
guru-ceb9c74e8c35f504028816b1b5ba3e8bf30322bb.tar.bz2
guru-ceb9c74e8c35f504028816b1b5ba3e8bf30322bb.zip
dev-python/inscriptis: add 2.3.2
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/inscriptis/Manifest1
-rw-r--r--dev-python/inscriptis/inscriptis-2.3.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/inscriptis/Manifest b/dev-python/inscriptis/Manifest
index 89d96aaec..d78eb3c51 100644
--- a/dev-python/inscriptis/Manifest
+++ b/dev-python/inscriptis/Manifest
@@ -1 +1,2 @@
DIST inscriptis-2.3.1.gh.tar.gz 982171 BLAKE2B 632cc80d3de7c770f604c957ea5636260e382406e33157ebf24d75b9690194be72e5dc4b3904410efd0b34a54cced8e84e7d98ddcc48bf0b1a43e824568b00a3 SHA512 c5820f21b7cd79e68042fc13519f1221fbd0897c1a76816293bd569b4b6a3e2945979bd941a8243223254a9687c5063ab77243f9a162baa490585f7f4c14ed8b
+DIST inscriptis-2.3.2.gh.tar.gz 981839 BLAKE2B 6e927b0bed25908868b4f66d28fbc0136af32f9210c4b583ed0eaef1552cb57b069ac0111ca799291ef83b3f20223248da6addd5ec4e4c98f78aa3a6b709cfad SHA512 87b525b0e9cf8d726d62515dba3b3d27328dfadb9854613e2c43d12a51c309e98e834d414651c25199b576e71e0a79fd11bdde43cc00d89f66b4b08b76bbb26a
diff --git a/dev-python/inscriptis/inscriptis-2.3.2.ebuild b/dev-python/inscriptis/inscriptis-2.3.2.ebuild
new file mode 100644
index 000000000..a18b9579b
--- /dev/null
+++ b/dev-python/inscriptis/inscriptis-2.3.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="HTML to text converter"
+HOMEPAGE="
+ https://pypi.org/project/inscriptis/
+ https://github.com/weblyzard/inscriptis
+"
+SRC_URI="https://github.com/weblyzard/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+DOCS=( AUTHORS {CONTRIBUTING,RENDERING}.md README.rst TODO.txt )
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs \
+ dev-python/myst_parser \
+ dev-python/alabaster