aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2024-11-09 15:12:24 +0300
committerAlexander Golubev <fatzer2@gmail.com>2024-11-09 15:19:34 +0300
commitae38058e9ea508cdee38f8836a9a406d76b22bd2 (patch)
tree2c2202fa2c7f6b74dc3d980492aa79b79be0fc24 /dev-libs
parentdev-cpp/scnlib: drop 3.0.1 (diff)
downloadguru-ae38058e9ea508cdee38f8836a9a406d76b22bd2.tar.gz
guru-ae38058e9ea508cdee38f8836a9a406d76b22bd2.tar.bz2
guru-ae38058e9ea508cdee38f8836a9a406d76b22bd2.zip
dev-libs/asmjit: new package, add 2024.10.25, 9999
Imported from the main tree because a version bump were required Signed-off-by: Alexander Golubev <fatzer2@gmail.com>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/asmjit/Manifest1
-rw-r--r--dev-libs/asmjit/asmjit-2024.10.25.ebuild33
-rw-r--r--dev-libs/asmjit/asmjit-9999.ebuild33
-rw-r--r--dev-libs/asmjit/metadata.xml11
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-libs/asmjit/Manifest b/dev-libs/asmjit/Manifest
new file mode 100644
index 000000000..df923fb6f
--- /dev/null
+++ b/dev-libs/asmjit/Manifest
@@ -0,0 +1 @@
+DIST asmjit-2024.10.25.tar.gz 1184167 BLAKE2B 2b07a470f1b7a3886aa67bd3d8efeb35f7218622df0f21da398b724226fa7253c37c3548f9a3f29ce0d2306794af02642969e9623829750e7ed6a0e6abfd88de SHA512 aef778b28bfb7187c93f5a7c8edacbb4d57b79d32b09ce30eab52e1708f641b123d19d5501c14625a155b4add8499782f4207145addbdf670266bc121d11138b
diff --git a/dev-libs/asmjit/asmjit-2024.10.25.ebuild b/dev-libs/asmjit/asmjit-2024.10.25.ebuild
new file mode 100644
index 000000000..69fb1376f
--- /dev/null
+++ b/dev-libs/asmjit/asmjit-2024.10.25.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="Machine code generation for C++"
+HOMEPAGE="https://asmjit.com/"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/asmjit/asmjit"
+else
+ CommitId=f1096428b87e9d16305de16e91f2a7f52aef5a88
+ SRC_URI="https://github.com/asmjit/${PN}/archive/${CommitId}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}"/${PN}-${CommitId}
+fi
+
+LICENSE="ZLIB"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="test? ( dev-cpp/gtest )"
+RESTRICT="!test? ( test )"
+
+DOCS=( README.md CONTRIBUTING.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DASMJIT_TEST=$(usex test)
+ )
+ cmake_src_configure
+}
diff --git a/dev-libs/asmjit/asmjit-9999.ebuild b/dev-libs/asmjit/asmjit-9999.ebuild
new file mode 100644
index 000000000..69fb1376f
--- /dev/null
+++ b/dev-libs/asmjit/asmjit-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="Machine code generation for C++"
+HOMEPAGE="https://asmjit.com/"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/asmjit/asmjit"
+else
+ CommitId=f1096428b87e9d16305de16e91f2a7f52aef5a88
+ SRC_URI="https://github.com/asmjit/${PN}/archive/${CommitId}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}"/${PN}-${CommitId}
+fi
+
+LICENSE="ZLIB"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="test? ( dev-cpp/gtest )"
+RESTRICT="!test? ( test )"
+
+DOCS=( README.md CONTRIBUTING.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DASMJIT_TEST=$(usex test)
+ )
+ cmake_src_configure
+}
diff --git a/dev-libs/asmjit/metadata.xml b/dev-libs/asmjit/metadata.xml
new file mode 100644
index 000000000..9a8fc8c2b
--- /dev/null
+++ b/dev-libs/asmjit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>fatzer2@gmail.com</email>
+ <name>Alexander Golubev</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">asmjit/asmjit</remote-id>
+ </upstream>
+</pkgmetadata>