aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOkamura Kazuya <gentoo-guru@danceylove.net>2023-06-28 00:27:33 +0900
committerOkamura Kazuya <gentoo-guru@danceylove.net>2023-06-28 00:27:33 +0900
commite01c54343b75e3e083758f6897200e72dfeee06a (patch)
tree472cc67ac53511f4d53f62715e4af99787c55f12 /dev-libs/lsbcrypt
parentdev-libs/ls-qpack: new package, add 2.5.0 (diff)
downloadguru-e01c54343b75e3e083758f6897200e72dfeee06a.tar.gz
guru-e01c54343b75e3e083758f6897200e72dfeee06a.tar.bz2
guru-e01c54343b75e3e083758f6897200e72dfeee06a.zip
dev-libs/lsbcrypt: new package, add 1.0.0
Signed-off-by: Okamura Kazuya <gentoo-guru@danceylove.net>
Diffstat (limited to 'dev-libs/lsbcrypt')
-rw-r--r--dev-libs/lsbcrypt/lsbcrypt-1.0.0.ebuild37
-rw-r--r--dev-libs/lsbcrypt/metadata.xml11
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/lsbcrypt/lsbcrypt-1.0.0.ebuild b/dev-libs/lsbcrypt/lsbcrypt-1.0.0.ebuild
new file mode 100644
index 000000000..e0196648b
--- /dev/null
+++ b/dev-libs/lsbcrypt/lsbcrypt-1.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake git-r3
+
+DESCRIPTION="libcrypt Wrapper for LiteSpeedTech"
+HOMEPAGE="https://github.com/litespeedtech/libbcrypt/"
+EGIT_REPO_URI="https://github.com/litespeedtech/libbcrypt/"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_prepare() {
+ eapply_user
+}
+
+src_configure() {
+ true
+}
+
+src_compile() {
+ make
+}
+
+src_install() {
+ true
+}
+
+pkg_preinst() {
+ mkdir -p ${D}/usr/lib/
+ mkdir -p ${D}/usr/include/
+ cp -a ${S}/bcrypt.h ${D}/usr/include/
+ cp -a ${S}/bcrypt.a ${D}/usr/lib/
+}
diff --git a/dev-libs/lsbcrypt/metadata.xml b/dev-libs/lsbcrypt/metadata.xml
new file mode 100644
index 000000000..366501a50
--- /dev/null
+++ b/dev-libs/lsbcrypt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo-guru@danceylove.net</email>
+ <name>Okamura Kazuya</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">litespeedtech/libbcrypt</remote-id>
+ </upstream>
+</pkgmetadata>