aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-07-14 18:15:19 +0200
committerHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-07-14 18:16:05 +0200
commite42c57afb4a8bdc581386f06c883e88e5337029a (patch)
treed5acfdf04e9d7a49e2331da9f42db3992e7f28e6 /dev-hare/hare-ssh/hare-ssh-0.24.2.ebuild
parentsys-kernel/uek-sources: update genpatches (diff)
downloadguru-e42c57afb4a8bdc581386f06c883e88e5337029a.tar.gz
guru-e42c57afb4a8bdc581386f06c883e88e5337029a.tar.bz2
guru-e42c57afb4a8bdc581386f06c883e88e5337029a.zip
dev-hare/hare-ssh: add 0.24.2
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Diffstat (limited to 'dev-hare/hare-ssh/hare-ssh-0.24.2.ebuild')
-rw-r--r--dev-hare/hare-ssh/hare-ssh-0.24.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-hare/hare-ssh/hare-ssh-0.24.2.ebuild b/dev-hare/hare-ssh/hare-ssh-0.24.2.ebuild
new file mode 100644
index 000000000..c207a2c08
--- /dev/null
+++ b/dev-hare/hare-ssh/hare-ssh-0.24.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ "${PV}" = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~sircmpwn/hare-ssh"
+ SLOT="0"
+else
+ SRC_URI="https://git.sr.ht/~sircmpwn/hare-ssh/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SLOT="0/${PV}"
+
+ KEYWORDS="~amd64 ~arm64 ~riscv"
+fi
+
+DESCRIPTION="SSH library for Hare"
+HOMEPAGE="https://git.sr.ht/~sircmpwn/hare-ssh"
+LICENSE="MPL-2.0"
+
+RDEPEND=">=dev-lang/hare-0.24.2"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i 's;^PREFIX=.*;PREFIX=/usr;' Makefile || die
+}