aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortea <gentoo@tastytea.de>2024-07-21 15:52:00 +0200
committertea <gentoo@tastytea.de>2024-07-21 16:55:50 +0200
commitfdb057509748c9f60aeaac153aa83331814feacc (patch)
tree86dfb873cfcd04ec3f1cfbb3324642ce077412d4 /dev-cpp
parentdev-cpp/trantor: add 1.5.20 (diff)
downloadguru-fdb057509748c9f60aeaac153aa83331814feacc.tar.gz
guru-fdb057509748c9f60aeaac153aa83331814feacc.tar.bz2
guru-fdb057509748c9f60aeaac153aa83331814feacc.zip
dev-cpp/trantor: drop 1.5.18
Signed-off-by: tea <gentoo@tastytea.de>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/trantor/Manifest1
-rw-r--r--dev-cpp/trantor/trantor-1.5.18.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/dev-cpp/trantor/Manifest b/dev-cpp/trantor/Manifest
index 2dd6f6aab..2b3c5d16e 100644
--- a/dev-cpp/trantor/Manifest
+++ b/dev-cpp/trantor/Manifest
@@ -1,3 +1,2 @@
-DIST trantor-1.5.18.tar.gz 155626 BLAKE2B 7fdd5fdd310b783dbc23be7e3594fe3e4e5135c1fcd7c9c96e153ff28397e543a4be50153e54f4a4f648de21d6c9ca5ffa85518806b7e6d91485956f3b3627b3 SHA512 2dba27efad95155a76968959d9bd2510be8502b9424716493f385aebbce2481553cc8fae283076029aed4bef6f0aadb0bec3f9acb98fbca3ef4d49b936558f8c
DIST trantor-1.5.19.tar.gz 156467 BLAKE2B 9683cc3691389a48be1060e05c96329f826b976b4090b869d5ea097b30b33d22bd1f5373987d5900f5f2f587227eb59c442bbfb0126cce1636887472352af948 SHA512 76264df770b14702cae88bb77c8e863e85eb034fd14bb062d3414f981b759be61bff3ce5aa1c8cca44bf0ca0b3568ed77248c9986eb23b6715631cdae9445a02
DIST trantor-1.5.20.tar.gz 156703 BLAKE2B 628c8ccae86809f0cd547eb991a67456f871d8ad4aa9606933ce91f98744c2faeb83b41d098811757ae6fcb0e221d5fe389d9684d98fa9c40570f8202b0489d3 SHA512 3666a49de1f13f52bac6d11d7c690c1d51b73d6f7e50b2a7591cd590639f88e33282d8b6b422f518ab73b42ba2d69d6db0852338563b366c548daaba09d0b49c
diff --git a/dev-cpp/trantor/trantor-1.5.18.ebuild b/dev-cpp/trantor/trantor-1.5.18.ebuild
deleted file mode 100644
index 4a18bcd7b..000000000
--- a/dev-cpp/trantor/trantor-1.5.18.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Non-blocking I/O tcp network lib based on c++14/17"
-HOMEPAGE="https://github.com/an-tao/trantor"
-SRC_URI="https://github.com/an-tao/trantor/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="adns doc +spdlog +ssl test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- adns? ( net-dns/c-ares:= )
- ssl? ( dev-libs/openssl:= )
- spdlog? (
- dev-libs/spdlog:=
- dev-libs/libfmt:=
- )
-"
-DEPEND="
- ${RDEPEND}
- test? ( dev-cpp/gtest )
-"
-BDEPEND="doc? ( app-text/doxygen[dot] )"
-
-src_prepare() {
- sed -i 's/ -Werror)$/)/' CMakeLists.txt || die "could not remove -Werror"
- cmake_src_prepare
-}
-
-src_configure() {
- local -a mycmakeargs=(
- "-DBUILD_SHARED_LIBS=YES"
- "-DBUILD_DOC=$(usex doc)"
- "-DBUILD_TESTING=$(usex test)"
- "-DBUILD_C-ARES=$(usex adns)"
- "-DTRANTOR_USE_TLS=$(usex ssl openssl none)"
- "-DUSE_SPDLOG=$(usex spdlog)"
- )
-
- cmake_src_configure
-}
-
-src_install() {
- use doc && HTML_DOCS="${BUILD_DIR}/docs/trantor/html/*"
-
- cmake_src_install
-}