aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent de Phily <moltonel@gmail.com>2021-08-28 14:13:31 +0100
committerVincent de Phily <moltonel@gmail.com>2021-08-28 14:13:31 +0100
commit5d8114518bb162b214bc1396025912388754dcf5 (patch)
tree38a1ef982abbf2f1dc8fae59b183beab4f2ce1ae /app-portage
parentmedia-sound/spotify_dl: 7.6.0 fixes (diff)
downloadguru-5d8114518bb162b214bc1396025912388754dcf5.tar.gz
guru-5d8114518bb162b214bc1396025912388754dcf5.tar.bz2
guru-5d8114518bb162b214bc1396025912388754dcf5.zip
app-portage/emlop: Fix shell completion on first install
As repored/fixed in https://github.com/vincentdephily/moltonel-ebuilds/issues/2 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Vincent de Phily <moltonel@gmail.com>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/emlop/emlop-0.4.1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/app-portage/emlop/emlop-0.4.1.ebuild b/app-portage/emlop/emlop-0.4.1.ebuild
index c04be2923..68cef1c2d 100644
--- a/app-portage/emlop/emlop-0.4.1.ebuild
+++ b/app-portage/emlop/emlop-0.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2017-2020 Gentoo Authors
+# Copyright 2017-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -90,16 +90,16 @@ src_install() {
cargo_src_install
einstalldocs
if use bash-completion; then
- emlop complete bash > emlop
+ ./target/release/emlop complete bash > emlop
dobashcomp emlop
fi
if use zsh-completion; then
- emlop complete zsh > _emlop
+ ./target/release/emlop complete zsh > _emlop
insinto /usr/share/zsh/site-functions
doins _emlop
fi
if use fish-completion; then
- emlop complete fish > emlop.fish
+ ./target/release/emlop complete fish > emlop.fish
insinto /usr/share/fish/vendor_completions.d
doins emlop.fish
fi