aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKostadin Shishmanov <kocelfc@tutanota.com>2023-11-01 18:19:51 +0200
committerKostadin Shishmanov <kocelfc@tutanota.com>2023-11-01 18:19:51 +0200
commit2ad7ceba48cb37f84deb7444edee1252f641c7a9 (patch)
tree917ffafd82a72e9c96eb3377c35e0e9775172e78 /app-misc/corectrl
parentnet-vpn/mullvadvpn-app: update icon cache and desktop db (diff)
downloadguru-2ad7ceba48cb37f84deb7444edee1252f641c7a9.tar.gz
guru-2ad7ceba48cb37f84deb7444edee1252f641c7a9.tar.bz2
guru-2ad7ceba48cb37f84deb7444edee1252f641c7a9.zip
app-misc/corectrl: add 1.3.7
Signed-off-by: Kostadin Shishmanov <kocelfc@tutanota.com>
Diffstat (limited to 'app-misc/corectrl')
-rw-r--r--app-misc/corectrl/Manifest1
-rw-r--r--app-misc/corectrl/corectrl-1.3.7.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-misc/corectrl/Manifest b/app-misc/corectrl/Manifest
index ef8fb34e4..ad85c4d9b 100644
--- a/app-misc/corectrl/Manifest
+++ b/app-misc/corectrl/Manifest
@@ -1 +1,2 @@
DIST corectrl-v1.3.6.tar.bz2 570738 BLAKE2B 8ff9255c67836e6826ea76663d1dcc8b39b024d806a75279ab5065550b1c9b1b54ed33acbf255a6c41f603df3146988c82df0c4c3f12e9e1f345c0eba432f361 SHA512 7f7718176a566c3f8d3b236c41a283d0b61f83c0dcc5954845214bb7b174bdff775e05d563c02b3fe17f2224541b0defc7900bbab6b0498d4bb02babfe4c8ce3
+DIST corectrl-v1.3.7.tar.bz2 570815 BLAKE2B fe8231ba71948d17b1e5d598bf19cde0e51ec13a20849b7bb12fa4cc8401d671123a5de00705cddd141e1ed68c097a315d676df060e704c5f0c0cf18c3383963 SHA512 f0c8ddc8180cb20935f58e0d473fc5436a430313f939adb6f1c41b0d278e689aaf6dd9d12b02ff81144dba494e713ccb4008bd3131bf8aa0769e13ac4de563be
diff --git a/app-misc/corectrl/corectrl-1.3.7.ebuild b/app-misc/corectrl/corectrl-1.3.7.ebuild
new file mode 100644
index 000000000..e56edefc6
--- /dev/null
+++ b/app-misc/corectrl/corectrl-1.3.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit ecm
+
+DESCRIPTION="Core control application"
+HOMEPAGE="https://gitlab.com/corectrl/corectrl"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/corectrl/corectrl.git"
+else
+ SRC_URI="https://gitlab.com/corectrl/corectrl/-/archive/v${PV}/corectrl-v${PV}.tar.bz2"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-v${PV}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtcharts:5[qml]
+ dev-qt/qtsvg:5
+ dev-qt/linguist-tools:5
+ dev-qt/qtquickcontrols2:5
+ dev-libs/quazip
+ dev-libs/botan:2
+ sys-auth/polkit
+ x11-libs/libdrm[video_cards_amdgpu]
+ dev-libs/libfmt
+ dev-libs/pugixml
+ dev-cpp/easyloggingpp
+ dev-cpp/units
+ test? (
+ ~dev-cpp/catch-2.13.8
+ dev-cpp/trompeloeil
+ )
+"
+
+BDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs+=(
+ -DBUILD_TESTING=$(usex test ON OFF)
+ )
+ cmake_src_configure
+}