aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2023-07-14 16:49:50 +0100
committerGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2023-07-14 16:54:35 +0100
commita4594255a5ccd63fb963240ccd2e568e0a423f5f (patch)
tree894faa82f0407f4a4b577d3a19954927a8972e38 /app-emulation
parentgui-libs/libdecor: new package, add 0.1.1, 9999 (diff)
downloadguru-a4594255a5ccd63fb963240ccd2e568e0a423f5f.tar.gz
guru-a4594255a5ccd63fb963240ccd2e568e0a423f5f.tar.bz2
guru-a4594255a5ccd63fb963240ccd2e568e0a423f5f.zip
app-emulation/LookingGlass: unkeyword 1_beta6 for ~amd64
* fix ExcessiveLineLength Signed-off-by: Gonçalo Negrier Duarte <gonegrier.duarte@gmail.com>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/LookingGlass/LookingGlass-1_beta6.ebuild43
-rw-r--r--app-emulation/LookingGlass/LookingGlass-9999.ebuild42
2 files changed, 20 insertions, 65 deletions
diff --git a/app-emulation/LookingGlass/LookingGlass-1_beta6.ebuild b/app-emulation/LookingGlass/LookingGlass-1_beta6.ebuild
index 40df5e4c0..24cb79032 100644
--- a/app-emulation/LookingGlass/LookingGlass-1_beta6.ebuild
+++ b/app-emulation/LookingGlass/LookingGlass-1_beta6.ebuild
@@ -12,7 +12,6 @@ HOMEPAGE="https://looking-glass.io https://github.com/gnif/LookingGlass"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64"
IUSE="binutils X wayland pipewire pulseaudio gnome"
REQUIRED_USE="|| ( binutils X wayland pipewire pulseaudio ) pipewire? ( !pulseaudio ) pulseaudio? ( !pipewire ) "
@@ -40,41 +39,19 @@ BDEPEND="virtual/pkgconfig"
CMAKE_USE_DIR="${S}"/client
-src_prepare() {
- default
-
+src_configure () {
# Base on build.rst from the project
- # https://github.com/gnif/LookingGlass/blob/master/doc/build.rst
-
- if ! use binutils; then
- MYCMAKEARGS=" -DENABLE_BACKTRACE=no "
- fi
-
- if ! use X; then
- MYCMAKEARGS=" ${MYCMAKEARGS} -DENABLE_X11=no "
- fi
-
- if ! use wayland; then
- MYCMAKEARGS=" ${MYCMAKEARGS} -DENABLE_WAYLAND=no "
- fi
+ # doc/build.rst
+ local mycmakeargs=(
+ -DENABLE_BACKTRACE=$(usex binutils) -DENABLE_X11=$(usex X) -DENABLE_WAYLAND=$(usex wayland) \
+ DENABLE_PIPEWIRE=$(usex pipewire) -DENABLE_PULSEAUDIO=$(usex pulseaudio) -DENABLE_LIBDECOR=$(usex gnome)
+ )
- if ! use pipewire; then
- MYCMAKEARGS=" ${MYCMAKEARGS} -DENABLE_PIPEWIRE=no "
- fi
-
- if ! use pulseaudio; then
- MYCMAKEARGS=" ${MYCMAKEARGS} -DENABLE_PULSEAUDIO=no "
- fi
-
- if ! use pulseaudio; then
- MYCMAKEARGS=" ${MYCMAKEARGS} -DENABLE_PULSEAUDIO=no "
- fi
-
- if use gnome && use wayland; then
- MYCMAKEARGS=" ${MYCMAKEARGS} -DENABLE_LIBDECOR=ON "
- fi
+ cmake_src_configure
+}
- cmake_src_prepare
+src_compile() {
+ cmake_src_compile
}
src_install() {
diff --git a/app-emulation/LookingGlass/LookingGlass-9999.ebuild b/app-emulation/LookingGlass/LookingGlass-9999.ebuild
index fb0224a86..59d91a492 100644
--- a/app-emulation/LookingGlass/LookingGlass-9999.ebuild
+++ b/app-emulation/LookingGlass/LookingGlass-9999.ebuild
@@ -38,41 +38,19 @@ BDEPEND="virtual/pkgconfig"
CMAKE_USE_DIR="${S}"/client
-src_prepare() {
- default
-
+src_configure () {
# Base on build.rst from the project
- # https://github.com/gnif/LookingGlass/blob/master/doc/build.rst
-
- if ! use binutils; then
- MYCMAKEARGS=" -DENABLE_BACKTRACE=no "
- fi
-
- if ! use X; then
- MYCMAKEARGS=" ${MYCMAKEARGS} -DENABLE_X11=no "
- fi
-
- if ! use wayland; then
- MYCMAKEARGS=" ${MYCMAKEARGS} -DENABLE_WAYLAND=no "
- fi
+ # doc/build.rst
+ local mycmakeargs=(
+ -DENABLE_BACKTRACE=$(usex binutils) -DENABLE_X11=$(usex X) -DENABLE_WAYLAND=$(usex wayland) \
+ DENABLE_PIPEWIRE=$(usex pipewire) -DENABLE_PULSEAUDIO=$(usex pulseaudio) -DENABLE_LIBDECOR=$(usex gnome)
+ )
- if ! use pipewire; then
- MYCMAKEARGS=" ${MYCMAKEARGS} -DENABLE_PIPEWIRE=no "
- fi
-
- if ! use pulseaudio; then
- MYCMAKEARGS=" ${MYCMAKEARGS} -DENABLE_PULSEAUDIO=no "
- fi
-
- if ! use pulseaudio; then
- MYCMAKEARGS=" ${MYCMAKEARGS} -DENABLE_PULSEAUDIO=no "
- fi
-
- if use gnome && use wayland; then
- MYCMAKEARGS=" ${MYCMAKEARGS} -DENABLE_LIBDECOR=ON "
- fi
+ cmake_src_configure
+}
- cmake_src_prepare
+src_compile() {
+ cmake_src_compile
}
src_install() {