aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Reed <david-gentoo@reedfam.email>2023-06-03 00:47:53 -0700
committerDavid Reed <david-gentoo@reedfam.email>2023-06-03 00:47:53 -0700
commite921048e316470147fb58385c3bedc1596113fa3 (patch)
tree7b10b9e1507691d30c1d6e5b923e54374b413c46 /app-containers
parentsys-libs/libnvidia-container: add 1.13.1 (diff)
downloadguru-e921048e316470147fb58385c3bedc1596113fa3.tar.gz
guru-e921048e316470147fb58385c3bedc1596113fa3.tar.bz2
guru-e921048e316470147fb58385c3bedc1596113fa3.zip
app-containers/nvidia-container-toolkit: add 1.13.1
Signed-off-by: David Reed <david-gentoo@reedfam.email>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/nvidia-container-toolkit/Manifest3
-rw-r--r--app-containers/nvidia-container-toolkit/nvidia-container-toolkit-1.13.1.ebuild68
2 files changed, 71 insertions, 0 deletions
diff --git a/app-containers/nvidia-container-toolkit/Manifest b/app-containers/nvidia-container-toolkit/Manifest
index c27ff2099..8525cfc91 100644
--- a/app-containers/nvidia-container-toolkit/Manifest
+++ b/app-containers/nvidia-container-toolkit/Manifest
@@ -1,3 +1,6 @@
DIST nvidia-container-toolkit-1.12.1-deps.tar.xz 16912940 BLAKE2B c4733beabf008f164d1ece29fd572d8735e9dd9c60d22fa2b226102382d077401a3d849746a914092750d12b0156de5a61c0dd6d6f61835a1df9d641c0bd51c0 SHA512 c1bcdd60ddfdd70ac335150815fb6fb7fcbc5ed4aa0ed119b4b915efa9600438a78c3d361ee4779055dc3b9e2e1fcb40377ca1580a96fd7370126f9d5c373b2d
DIST nvidia-container-toolkit-1.12.1-vendor.tar.xz 1101200 BLAKE2B 5343d8c0eed8715c0e06464f542e5874ae288717a3ec0e89e3f3fb0c4b3d406de192cea5131a992c7ab4cae7587fa2b2d91b331b3d5f81c24c2b83955c0ecec5 SHA512 3bd6f685e9273d65465a23f5d4ce9fcd95562afc30ab39dcac08eaf9d01a48d3a5cc195c4f48217bb2263af033b60c2d30d0c6309306057359a037959f806615
DIST nvidia-container-toolkit-1.12.1.tar.gz 2226106 BLAKE2B f2f68068bdfe5db6b733bb2c4f58ed2e6692382121955ed605469ca014422d24f979b3d0797f55c7d0bc99cd1458de469da66c5ad095ef0902f90f6c698ce433 SHA512 22cf523cfab0e619687a45442e53b127a1433503b50aef33c23d29e47e11371cdaa03dcd24ba4eb28c530fd905d09e76468365f096213f743ca8f9c585b679e5
+DIST nvidia-container-toolkit-1.13.1-deps.tar.xz 16932688 BLAKE2B 86e0b8c948b92c389279328e4505a8e5d189af4efa3b0fb12d1a1e374b070432667b5b2f65dc38a9d9f4d08e3b3af0c36c794790819316c64fd612e15b44f9d5 SHA512 dc5273395e730a8ef7c59507547c6a4d388c6252d1360295285e3576b3c4d2e87b809d1bf4f967f03ba1105c844250da2f6dd7ae45d2edea383c55435756f6e6
+DIST nvidia-container-toolkit-1.13.1-vendor.tar.xz 1107124 BLAKE2B 186952ded4bb979d24aa4beca87ceb2495530b4221cf9778b227c869c1f2b3d0b4957227e9c71d7d9596058df55d3e8fb6345515dbb43d408a7f2cc589928f89 SHA512 14121daf2351f7107c247ae2fa74e34d4b8cfb443c7b00386428a179a05de625a985622642ea9b16691b23ef4b49dac3f977a3b373e9ddd6adcf50c5d16b9dc9
+DIST nvidia-container-toolkit-1.13.1.tar.gz 2269989 BLAKE2B 48cdafa390320d467133ab5aa3d77d6bd1fc5c7fc3314c2d8f977de4fd4224b3da4e647cfeb8f3eb3b20c711a69471b57fbb3211954c3c77b7fb82ec807b5926 SHA512 e0d9dbb06e2b8ef075a881f4414bfb4b1ab9f571d148a202fbf7c2a7b59447f199028d5d176196703dadcb04040a74a229f09062da24e615faa4c051d614e206
diff --git a/app-containers/nvidia-container-toolkit/nvidia-container-toolkit-1.13.1.ebuild b/app-containers/nvidia-container-toolkit/nvidia-container-toolkit-1.13.1.ebuild
new file mode 100644
index 000000000..edefa60c2
--- /dev/null
+++ b/app-containers/nvidia-container-toolkit/nvidia-container-toolkit-1.13.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EGO_PN="github.com/NVIDIA/${PN}"
+
+inherit go-module
+
+DESCRIPTION="NVIDIA container runtime toolkit"
+HOMEPAGE="https://github.com/NVIDIA/nvidia-container-toolkit"
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/NVIDIA/${PN}.git"
+ inherit git-r3
+
+ src_unpack() {
+ git-r3_src_unpack
+ go-module_live_vendor
+ }
+else
+ SRC_URI="
+ https://github.com/NVIDIA/${PN}/archive/v${PV/_rc/-rc.}.tar.gz -> ${P}.tar.gz
+ https://github.com/david-gentoo/gentoo-go-deps/releases/download/${P}/${P}-deps.tar.xz
+ https://github.com/david-gentoo/gentoo-go-deps/releases/download/${P}/${P}-vendor.tar.xz
+ "
+ S="${WORKDIR}/${PN}-${PV/_rc/-rc.}"
+ KEYWORDS="~amd64"
+ RESTRICT="mirror"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+IUSE=""
+
+RDEPEND="
+ sys-libs/libnvidia-container
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ app-arch/unzip
+ sys-devel/make
+"
+
+src_compile() {
+ emake binaries
+}
+
+src_install() {
+ # Fixed by https://github.com/vizv
+ dobin "nvidia-container-runtime"
+ dobin "nvidia-container-runtime-hook"
+ dobin "nvidia-ctk"
+ insinto "/etc/nvidia-container-runtime"
+ doins "${FILESDIR}/config.toml"
+}
+
+pkg_postinst() {
+ elog "Your docker service must restart after install this package."
+ elog "OpenRC: sudo rc-service docker restart"
+ elog "systemd: sudo systemctl restart docker"
+ elog "You may need to edit your /etc/nvidia-container-runtime/config.toml"
+ elog "file before running ${PN} for the first time."
+ elog "For details, please see the NVIDIA docker manual page."
+}