aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Reva <denis7774@gmail.com>2022-12-28 11:12:09 +0500
committerDenis Reva <denis7774@gmail.com>2022-12-28 11:12:29 +0500
commit935d044fa6cd46693239f2f5475619edeff1fe9b (patch)
tree94a2413f50793f86ba850e16d1f709d9df555a91 /app-containers
parentgui-apps/tootle: drop empty keywords (diff)
downloadguru-935d044fa6cd46693239f2f5475619edeff1fe9b.tar.gz
guru-935d044fa6cd46693239f2f5475619edeff1fe9b.tar.bz2
guru-935d044fa6cd46693239f2f5475619edeff1fe9b.zip
app-containers/waydroid: Changed category of waydroid from app-emulation
cause it container-based approach Bug: https://bugs.gentoo.org/834025 Signed-off-by: Denis Reva <denis7774@gmail.com>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/waydroid/Manifest1
-rw-r--r--app-containers/waydroid/files/waydroid9
-rw-r--r--app-containers/waydroid/metadata.xml19
-rw-r--r--app-containers/waydroid/waydroid-1.3.4-r5.ebuild72
4 files changed, 101 insertions, 0 deletions
diff --git a/app-containers/waydroid/Manifest b/app-containers/waydroid/Manifest
new file mode 100644
index 0000000000..85bc684294
--- /dev/null
+++ b/app-containers/waydroid/Manifest
@@ -0,0 +1 @@
+DIST waydroid-1.3.4.tar.gz 231638 BLAKE2B 73418208e484172745208caa89442478643327a77a8642536a26c538129ce57e643728a22d64393b4d344502b221b124c4000c1df0838aefc5af6996e7e8bab3 SHA512 2c7feb8cfe2b6e2738159d07e12f378250f5ba6a0d0f47c0ff904af934eacde193ae0fcae1cb4fb67d1687a2ffcd2864c1eea4fa5e52c19685ffad5c702359a5
diff --git a/app-containers/waydroid/files/waydroid b/app-containers/waydroid/files/waydroid
new file mode 100644
index 0000000000..d9e5905921
--- /dev/null
+++ b/app-containers/waydroid/files/waydroid
@@ -0,0 +1,9 @@
+#!/usr/bin/openrc-run
+description="Waydroid Container Manager"
+start() {
+ waydroid container start &
+}
+stop() {
+ waydroid container stop
+ waydroid session stop
+} \ No newline at end of file
diff --git a/app-containers/waydroid/metadata.xml b/app-containers/waydroid/metadata.xml
new file mode 100644
index 0000000000..07f40006d9
--- /dev/null
+++ b/app-containers/waydroid/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'http://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>denis7774@gmail.com</email>
+ <name>Denis Reva</name>
+ <description>rarogcmex</description>
+ </maintainer>
+ <longdescription lang="en">
+ Waydroid uses Linux namespaces (user, pid, uts, net, mount, ipc) to run a full Android system in a container and provide Android applications on any GNU/Linux-based platform.
+
+ The Android system inside the container has direct access to any needed hardware.
+
+ The Android runtime environment ships with a minimal customized Android system image based on LineageOS. The image is currently based on Android 11.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">waydroid/waydroid</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-containers/waydroid/waydroid-1.3.4-r5.ebuild b/app-containers/waydroid/waydroid-1.3.4-r5.ebuild
new file mode 100644
index 0000000000..df767cedce
--- /dev/null
+++ b/app-containers/waydroid/waydroid-1.3.4-r5.ebuild
@@ -0,0 +1,72 @@
+#Relaismatrix/ Messung Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit linux-info xdg-utils python-single-r1
+
+DESCRIPTION="Container-based approach to boot a full Android system on Linux systems"
+HOMEPAGE="https://waydro.id"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+IUSE="systemd apparmor"
+
+DEPEND="|| ( virtual/linux-sources virtual/dist-kernel )"
+RDEPEND="
+ systemd? ( sys-apps/systemd )
+ app-containers/lxc[systemd?,apparmor?,seccomp]
+ $(python_gen_cond_dep '
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ >=dev-python/gbinder-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/pyclip-0.7.0[wayland,${PYTHON_USEDEP}]
+ ')
+ net-firewall/nftables[modern-kernel]
+ net-dns/dnsmasq
+ >=dev-libs/libglibutil-1.0.67
+ >=dev-libs/gbinder-1.1.21
+ ${PYTHON_DEPS}
+"
+
+CONFIG_CHECK="
+ ~ANDROID_BINDER_IPC
+ ~ANDROID_BINDERFS
+ ~MEMFD_CREATE
+"
+ERROR_ANDROID_BINDERFS="CONFIG_ANDROID_BINDERFS: need for creating Android-specific binder IPC channels"
+ERROR_ANDROID_BINDER_IPC="CONFIG_ANDROID_BINDER_IPC: need for creating Android-specific binder IPC channels"
+ERROR_MEMFD_CREATE="CONFIG_MEMFD_CREATE: it completely replaced deprecated ISHMEM drivers,
+ therefore it's vital for android-specific memory management"
+
+src_install() {
+ python_fix_shebang waydroid.py
+ emake install DESTDIR="${D}" USE_NFTABLES=1 USE_SYSTEMD=$(usex systemd 1 0)
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+
+ if not use apparmor; then
+ ewarn "If you use app-containers/lxc without apparmor, make sure you deleted or commented out in waydroid LXC config"
+ ewarn "(generated after waydroid init) in /var/lib/waydroid/lxc/waydroid/config the following string:"
+ ewarn "lxc.apparmor.profile = unconfined"
+ ewarn "or waydroid experiences crash during launch"
+ ewarn "See also https://github.com/waydroid/waydroid/issues/652"
+ else
+ ewarn "Apparmor support has not been tested by package maintainer yet"
+ fi
+ ewarn "Make sure you have NFTABLES up and running in your kernel. See"
+ ewarn "https://wiki.gentoo.org/wiki/Nftables for how-to details"
+ einfo "Contact https://docs.waydro.id/usage/install-on-desktops for how-to guides"
+ einfo "(does not cover Gentoo-specific things sadly)"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}