aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNRK <nrk@disroot.org>2024-02-24 15:46:14 +0000
committerNRK <nrk@disroot.org>2024-02-26 17:45:01 +0000
commitd00074052481cbb468d930cc42caeaa6990d1987 (patch)
tree52d85e377e0c195108eb4d90f57bb46609aae98b /app-arch
parentapp-arch/7zip: add support for dev-lang/uasm (diff)
downloadguru-d00074052481cbb468d930cc42caeaa6990d1987.tar.gz
guru-d00074052481cbb468d930cc42caeaa6990d1987.tar.bz2
guru-d00074052481cbb468d930cc42caeaa6990d1987.zip
app-arch/7zip: disable executable stack when using uasm
Signed-off-by: NRK <nrk@disroot.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/7zip/7zip-23.01.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/app-arch/7zip/7zip-23.01.ebuild b/app-arch/7zip/7zip-23.01.ebuild
index 7fe4ad21c..414d6e33b 100644
--- a/app-arch/7zip/7zip-23.01.ebuild
+++ b/app-arch/7zip/7zip-23.01.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit edos2unix toolchain-funcs
+inherit edos2unix toolchain-funcs flag-o-matic
NO_DOT_PV=$(ver_rs 1- '')
DESCRIPTION="A free file archiver for extremely high compression"
@@ -21,7 +21,6 @@ RESTRICT="mirror"
RDEPEND=""
DEPEND="${RDEPEND}"
-# TODO: disable executable stack when asm is used
BDEPEND="
uasm? ( dev-lang/uasm )
jwasm? ( dev-lang/jwasm )
@@ -61,6 +60,7 @@ src_prepare() {
src_compile() {
pushd "./Bundles/Alone2" || die "Unable to switch directory"
+ append-ldflags -Wl,-z,noexecstack
export G_CC=$(tc-getCC)
export G_CXX=$(tc-getCXX)
export G_CFLAGS=${CFLAGS}