aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStepan Kulikov <stepan_kk@pm.me>2023-06-21 23:28:23 +0300
committerStepan Kulikov <stepan_kk@pm.me>2023-06-21 23:28:23 +0300
commitbc46fa1c58c1d493892d6fb339b34f58636b3846 (patch)
treee322bb74ef411525f667ef095b02ab7179a6ca8e /app-admin
parentapp-portage/gentle: add 0.2 (diff)
downloadguru-bc46fa1c58c1d493892d6fb339b34f58636b3846.tar.gz
guru-bc46fa1c58c1d493892d6fb339b34f58636b3846.tar.bz2
guru-bc46fa1c58c1d493892d6fb339b34f58636b3846.zip
app-admin/gentoo_update: version bump, notify about optional deps via optfeature
version bump from 0.1.4 -> 0.1.6 use optfeature eclass to notify users about optional dependencies Signed-off-by: Stepan Kulikov <stepan_kk@pm.me>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/gentoo_update/Manifest2
-rw-r--r--app-admin/gentoo_update/gentoo_update-0.1.4.ebuild7
2 files changed, 7 insertions, 2 deletions
diff --git a/app-admin/gentoo_update/Manifest b/app-admin/gentoo_update/Manifest
index e9d7a74cf..f8ff33989 100644
--- a/app-admin/gentoo_update/Manifest
+++ b/app-admin/gentoo_update/Manifest
@@ -1,2 +1,2 @@
-DIST gentoo_update-0.1.4.gh.tar.gz 7757 BLAKE2B 1455dcc51d43448701cc2ffc93330baf7e5fb516fa9e42757156133ace1c60943b85f58ab120129123ac567f0fc4e133b67cd6cb9c48a67d8763cf3b1df362bd SHA512 8a89ef60253948b8526ffcb75d95619df68ffd3f5c593080f14f05242b8bcd6f2951619fda15d054730fdeebbba58292fd7a30f146d8798c72c97037503b1518
+DIST gentoo_update-0.1.6.gh.tar.gz 8543 BLAKE2B eb807ed2ded5912357a6211c495605ceb923c2e48ef30aafe5903a7999b60ccd724e0d9f683b6999df44789bd8003a0f6c97459543aa323a426bd153baea3bab SHA512 57b274b1e1f20fdc4505b31e9de6f59c0de09a30cc7bb5bfdf01038a9f0b84f0dd4562fc85d224d67a40c90f543da4f4d10abf9d168e5818ac5af2a45902b1ba
diff --git a/app-admin/gentoo_update/gentoo_update-0.1.4.ebuild b/app-admin/gentoo_update/gentoo_update-0.1.4.ebuild
index 8ecaee677..0bd0c19bd 100644
--- a/app-admin/gentoo_update/gentoo_update-0.1.4.ebuild
+++ b/app-admin/gentoo_update/gentoo_update-0.1.4.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..11} )
-inherit distutils-r1
+inherit distutils-r1 optfeature
DESCRIPTION="Gentoo Linux updater"
HOMEPAGE="https://github.com/Lab-Brat/gentoo_update"
@@ -20,3 +20,8 @@ python_test() {
cd tests || die
eunittest
}
+
+pkg_postinst() {
+ optfeature "--clean support" app-portage/gentoolkit
+ optfeature "--deamon-reload support" app-admin/needrestart
+}