aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Kappus <joe@wt.gd>2024-04-21 18:38:28 -0400
committerJoe Kappus <joe@wt.gd>2024-04-21 18:38:28 -0400
commit8b6eb58994c3162b49962a2c8cb5fac8e67a7036 (patch)
tree54046fe0a7341db3f96d7e336ce08e3d20b57646 /app-admin
parentgui-libs/xdg-desktop-portal-hyprland: fix systemd path (diff)
downloadguru-8b6eb58994c3162b49962a2c8cb5fac8e67a7036.tar.gz
guru-8b6eb58994c3162b49962a2c8cb5fac8e67a7036.tar.bz2
guru-8b6eb58994c3162b49962a2c8cb5fac8e67a7036.zip
app-admin/s-tui: add 1.1.6
Signed-off-by: Joe Kappus <joe@wt.gd>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/s-tui/Manifest1
-rw-r--r--app-admin/s-tui/metadata.xml2
-rw-r--r--app-admin/s-tui/s-tui-1.1.6.ebuild34
3 files changed, 36 insertions, 1 deletions
diff --git a/app-admin/s-tui/Manifest b/app-admin/s-tui/Manifest
index 0dc193c77..0fabdf54b 100644
--- a/app-admin/s-tui/Manifest
+++ b/app-admin/s-tui/Manifest
@@ -1 +1,2 @@
DIST s-tui-1.1.4.gh.tar.gz 2608449 BLAKE2B 80dfc8c4dbce181cf50a5fe3bf05b553401f0cd17b184b9123e61807ee1e5c06bdbdf543fc86a0aca8f7aa4aa508e76756047a121e5d6ddbce167e097938a870 SHA512 20adfb27bae6467650a901211f4b58d0351d756a5b9465922953feb3711969c6d647782f99479475499b4658ef65da6283ad4e55ce72839d36c08f8a7f244322
+DIST s-tui-1.1.6.gh.tar.gz 2608253 BLAKE2B 64815def105ad3c57f2103841ad09948ec6205bda09f4afca7dcca3bb9586c3e8d08aa0524d42f086f589f613bd79b389fca0f55182391bf20679b4d040eb087 SHA512 73412b55175ca2a5e98e410a3c9b5ce9aa1cffc13eb9af26e834d0ea784c06f6a9f81bb1be028b8cf94046ff0a8b20fff5b1191c949d49a72cecf3abd6a1fc38
diff --git a/app-admin/s-tui/metadata.xml b/app-admin/s-tui/metadata.xml
index becc7655c..3431d6b87 100644
--- a/app-admin/s-tui/metadata.xml
+++ b/app-admin/s-tui/metadata.xml
@@ -3,7 +3,7 @@
<pkgmetadata>
<maintainer type="person">
<email>joe@wt.gd</email>
- <name>joecool</name>
+ <name>Joe Kappus</name>
</maintainer>
<upstream>
<remote-id type="github">amanusk/s-tui</remote-id>
diff --git a/app-admin/s-tui/s-tui-1.1.6.ebuild b/app-admin/s-tui/s-tui-1.1.6.ebuild
new file mode 100644
index 000000000..c98071774
--- /dev/null
+++ b/app-admin/s-tui/s-tui-1.1.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Stress-Terminal UI monitoring tool"
+HOMEPAGE="https://amanusk.github.io/s-tui/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/amanusk/${PN}.git"
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/amanusk/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/psutil-5.9.1[${PYTHON_USEDEP}]
+ >=dev-python/urwid-2.0.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+pkg_postinst() {
+ optfeature "Stress options in program menu" app-benchmarks/stress
+}