aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Zapparov <alexey@zapparov.com>2023-07-13 02:36:34 +0200
committerAlexey Zapparov <alexey@zapparov.com>2023-07-13 02:36:34 +0200
commit28f343ac776e6e664897c7c8811b28bf9eb4798d (patch)
tree0edf4e87c587e6bdef5e7251c7706d31625d8e36 /app-admin
parentapp-admin/chezmoi: add 2.34.3, drop 2.34.2 (diff)
downloadguru-28f343ac776e6e664897c7c8811b28bf9eb4798d.tar.gz
guru-28f343ac776e6e664897c7c8811b28bf9eb4798d.tar.bz2
guru-28f343ac776e6e664897c7c8811b28bf9eb4798d.zip
app-admin/pulumi-bin: add 3.75.0
Signed-off-by: Alexey Zapparov <alexey@zapparov.com>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/pulumi-bin/Manifest1
-rw-r--r--app-admin/pulumi-bin/pulumi-bin-3.75.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-admin/pulumi-bin/Manifest b/app-admin/pulumi-bin/Manifest
index 60ff1b791..3b4e33c58 100644
--- a/app-admin/pulumi-bin/Manifest
+++ b/app-admin/pulumi-bin/Manifest
@@ -1,3 +1,4 @@
DIST pulumi-v3.72.2-linux-x64.tar.gz 143301739 BLAKE2B e79d9a5dda71782c61a6bd02b5b64b0f042d1427c71c83e3878cdc5927d0d0ace628947da88486b232ebf835f25a5e598368cac4d8e11ac8a89f439941ac520e SHA512 374914b7df54718ef2f03ac9564bfcca042f40220c428b091d67377f119905e7a1b3dee6b3b15faee1be74b35c55be02f9d67ebec85f56255732a86f9ff4b837
DIST pulumi-v3.73.0-linux-x64.tar.gz 143303347 BLAKE2B fbc786dac43056545dafc7e99950fa6bcc2258779adcd18d012fc351e88f9f29ce700155c1d09221d13500e8d70f0e9c70641d5332bed91dcd3699e87b44a811 SHA512 a084b7d83e83be595b7ba37e95ba12466cdfef66c4afcd9ff00071d212bcdc8810c9a3cec669db7dd0d8ec952d57e0f7b6ddb835ad06c2f8917cc1fb57a9f43f
DIST pulumi-v3.74.0-linux-x64.tar.gz 143408310 BLAKE2B 8da70b0aae12b4adae556aa769b82348f54d40d8ac50002074caac74873d63cc0155a126abdad715da83bedb36e92f8e40a05a712335ae16b54d4c094696f751 SHA512 8e5e12a4c210601d7290a21e65b6860fa3980af2c67248aa6c1ba3a55441d9b7165686d7eec2c0029832dcc62715fcffef47d8d308069e6ebea386e992567ded
+DIST pulumi-v3.75.0-linux-x64.tar.gz 143145995 BLAKE2B 1260fc4db976ddedbd7a978f4ddfdcc0264dd194878d77b52faad985705931e1dec3a04f4b62097cd9a4c7326e6764ac41cda9d148de5185aa82e74cb9b53b9c SHA512 b46ae96bd50c2d32c9005e20c699c48dd105e36874d414eba53ec74f963497cef460efaf19021e6728b6de172d7791acaced41fc4f08102ce94d3e2f186370f9
diff --git a/app-admin/pulumi-bin/pulumi-bin-3.75.0.ebuild b/app-admin/pulumi-bin/pulumi-bin-3.75.0.ebuild
new file mode 100644
index 000000000..febb59ec1
--- /dev/null
+++ b/app-admin/pulumi-bin/pulumi-bin-3.75.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Infrastructure as code in any programming language"
+HOMEPAGE="
+ https://www.pulumi.com/
+ https://github.com/pulumi/pulumi
+"
+SRC_URI="
+ amd64? ( https://github.com/pulumi/pulumi/releases/download/v${PV}/pulumi-v${PV}-linux-x64.tar.gz )
+"
+
+S="${WORKDIR}/pulumi"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+QA_PREBUILT="*"
+
+src_install() {
+ dobin pulumi*
+
+ ./pulumi gen-completion bash > pulumi.bash-completion || die "Cannot generate bash completions"
+ newbashcomp pulumi.bash-completion pulumi
+
+ ./pulumi gen-completion zsh > pulumi.zsh-completion || die "Cannot generate zsh completions"
+ insinto /usr/share/zsh/site-functions
+ newins pulumi.zsh-completion _pulumi
+}