aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2024-11-19 17:49:55 +0100
committerDavid Roman <davidroman96@gmail.com>2024-11-19 17:50:10 +0100
commite56b2bac04ed17d552c5784eb93b6237cb7c9b7a (patch)
tree1614e6b9e91c1297c2aba26f108067527f79bb6a
parentdev-python/pillow-heif: drop 0.18.0 (diff)
downloadguru-e56b2bac04ed17d552c5784eb93b6237cb7c9b7a.tar.gz
guru-e56b2bac04ed17d552c5784eb93b6237cb7c9b7a.tar.bz2
guru-e56b2bac04ed17d552c5784eb93b6237cb7c9b7a.zip
dev-python/plexapi: add 4.16.0
Signed-off-by: David Roman <davidroman96@gmail.com>
-rw-r--r--dev-python/plexapi/Manifest1
-rw-r--r--dev-python/plexapi/plexapi-4.16.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/plexapi/Manifest b/dev-python/plexapi/Manifest
index 61d05ecbc..52134aaaf 100644
--- a/dev-python/plexapi/Manifest
+++ b/dev-python/plexapi/Manifest
@@ -1,2 +1,3 @@
DIST plexapi-4.15.15.gh.tar.gz 22523094 BLAKE2B e7e6412e779565066b13b6c0833bae7652cb8dbcbf00ea36734b54667c5214e398449983f891e19fe650fa5f786e69718a4a6ada963ea7d821b040a9c3d54f08 SHA512 90d82435008072b687a74683d2c230088a2bfefab990f5901cf0cf95e1a47273c886e2e4b591c695e2cc5733a58a4a1399033761d4c88d01b7810b352ea08904
DIST plexapi-4.15.16.gh.tar.gz 22524434 BLAKE2B d2166673fef5d865bf966deca16cecee40b8ed999f784a18c8d6ab17c63ba891433e29b6877c20b451bbda5ff35025cedc2515d1321fb2146411ccdc5f545999 SHA512 3b3e54340e6264be159b4380f29b2a785df3f550d14aa5a47ad628a2b09f5eaf94f1e9d472969d28bdce2feb61c1a8825a953f94a958db9a6a33d9755f57e0a4
+DIST plexapi-4.16.0.gh.tar.gz 22524954 BLAKE2B 3bd88f4a05ef0573ce58526fabaa658caae4979e429619d9e98e3dba30363318d3b10d6b32a7e96df101f62799b4cdb9406b4c1556aad33982dab98240d560c1 SHA512 cd68bbd3086ccbd926058fb904027cb2c9939e57e510527667e991de23aee4e5c3e13b09906edf7f529f85e46600e134b79fac1ed2ca219d8d6a0ff17ed7f4fe
diff --git a/dev-python/plexapi/plexapi-4.16.0.ebuild b/dev-python/plexapi/plexapi-4.16.0.ebuild
new file mode 100644
index 000000000..ccb7cd3b2
--- /dev/null
+++ b/dev-python/plexapi/plexapi-4.16.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# left here in case we switch to pypi
+PYPI_PN="PlexAPI"
+PYPI_NO_NORMALIZE=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the Plex API."
+HOMEPAGE="
+ https://pypi.org/project/PlexAPI/
+ https://github.com/pkkid/python-plexapi
+"
+
+# pypi release don't have docs
+SRC_URI="https://github.com/pkkid/python-plexapi/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+S="${WORKDIR}/python-${P}"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# almost all tests requires a running server
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+BDEPEND="doc? ( dev-python/sphinx-rtd-theme )"
+
+distutils_enable_sphinx docs