aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-06-28 05:53:38 +0400
committerVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-06-28 05:53:38 +0400
commit90288e42e6ca962564eb4b0a900c01c9275b805d (patch)
treebc7f53590a114d8a0c0f714d49b530080239656d
parentdev-util/lemminx-bin: drop 0.25.0 (diff)
downloadguru-90288e42e6ca962564eb4b0a900c01c9275b805d.tar.gz
guru-90288e42e6ca962564eb4b0a900c01c9275b805d.tar.bz2
guru-90288e42e6ca962564eb4b0a900c01c9275b805d.zip
sys-boot/grml-rescueboot: new package
Signed-off-by: Vitaly Zdanevich <zdanevich.vitaly@ya.ru>
-rw-r--r--sys-boot/grml-rescueboot/Manifest1
-rw-r--r--sys-boot/grml-rescueboot/grml-rescueboot-0.6.1.ebuild47
-rw-r--r--sys-boot/grml-rescueboot/metadata.xml11
3 files changed, 59 insertions, 0 deletions
diff --git a/sys-boot/grml-rescueboot/Manifest b/sys-boot/grml-rescueboot/Manifest
new file mode 100644
index 000000000..ddf57799f
--- /dev/null
+++ b/sys-boot/grml-rescueboot/Manifest
@@ -0,0 +1 @@
+DIST grml-rescueboot_0.6.1_all.deb 8308 BLAKE2B 0295172a2d89f50ed9f24848b6dcd3328066c4236c482b779126a54b81bbeb3dda644c201e6f1f5a550f1358c64bfb9539499ed1b956880ebc0890d0f36d6672 SHA512 d1c728941c526a44d87c7d0971541563d7dddba5f1c46e13091879d047910ada1b8d5e8756157f696530cbed95e66baf7948be1546e31bac6feff8df80fc3084
diff --git a/sys-boot/grml-rescueboot/grml-rescueboot-0.6.1.ebuild b/sys-boot/grml-rescueboot/grml-rescueboot-0.6.1.ebuild
new file mode 100644
index 000000000..359f6bb07
--- /dev/null
+++ b/sys-boot/grml-rescueboot/grml-rescueboot-0.6.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker
+
+DESCRIPTION="grub2 script to add ISO images to the grub2 boot menu"
+HOMEPAGE="http://wiki.grml.org/doku.php?id=rescueboot"
+
+SRC_URI="http://deb.grml.org/pool/main/g/${PN}/${PN}_${PV}_all.deb"
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ sys-boot/grub
+"
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_install() {
+ insinto /etc/default/
+ doins etc/default/grml-rescueboot
+
+ insinto /etc/grub.d/
+ doins etc/grub.d/42_grml
+ fperms +x /etc/grub.d/42_grml
+}
+
+pkg_postinst() {
+ einfo "Default folder for ISOs is /boot/grml/"
+ einfo "You can change it in /etc/default/grml-rescueboot"
+ einfo "Put some ISOs to the folder,"
+ einfo "mount your /boot:"
+ einfo "mount /dev/sda1 /boot/"
+ einfo "and run"
+ einfo "grub-mkconfig -o /boot/grub/grub.cfg"
+ einfo "Not all ISOs are bootable this way"
+ einfo "Works for Ubuntu, Debian (not all ISOs)"
+ einfo "https://grml.org/download/"
+ einfo "but not for Gentoo ISO, see https://bugs.gentoo.org/568464"
+}
diff --git a/sys-boot/grml-rescueboot/metadata.xml b/sys-boot/grml-rescueboot/metadata.xml
new file mode 100644
index 000000000..e76146669
--- /dev/null
+++ b/sys-boot/grml-rescueboot/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>zdanevich.vitaly@ya.ru</email>
+ <name>Vitaly Zdanevich</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">grml/grml-rescueboot</remote-id>
+ </upstream>
+</pkgmetadata>