aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2023-11-04 20:59:16 +0100
committerPascal Jäger <pascal.jaeger@leimstift.de>2023-11-04 20:59:16 +0100
commit7ed059b678c4ec4c4ee9d11bc7be53e56c9983b8 (patch)
treed3ecc337c3b59b7064c7600b23b3c76cf6285fa9
parentgames-engines/fs2_open: add 23.2.1, drop 23.2.0 (diff)
downloadguru-7ed059b678c4ec4c4ee9d11bc7be53e56c9983b8.tar.gz
guru-7ed059b678c4ec4c4ee9d11bc7be53e56c9983b8.tar.bz2
guru-7ed059b678c4ec4c4ee9d11bc7be53e56c9983b8.zip
gui-apps/nwg-shell: add 0.5.18
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
-rw-r--r--gui-apps/nwg-shell/Manifest1
-rw-r--r--gui-apps/nwg-shell/nwg-shell-0.5.18.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/gui-apps/nwg-shell/Manifest b/gui-apps/nwg-shell/Manifest
index 01976bce1..4efa604cb 100644
--- a/gui-apps/nwg-shell/Manifest
+++ b/gui-apps/nwg-shell/Manifest
@@ -1,2 +1,3 @@
DIST nwg-shell-0.5.16.tar.gz 2180688 BLAKE2B 174a281557bf292ba333d85ed55ad4cce893a151b8d9247e51e6e7e6d0cc207f419d48708df1ac6fcebc300c7d2ac97b3e3d8a168d11da729d80c35e1fe6fb6a SHA512 6f1d625e361bdc6abeab37b53e0518a146786b9ab21fb171c4e830fd0a9bf8e772a512d474db14d61d83d9421d08543694fca4dd9638e00db27394bdaeb9246d
+DIST nwg-shell-0.5.18.tar.gz 2180700 BLAKE2B fc5aa5f6fa1218ea19081f64b40325832f4bf5997ce3f9764147fa8c7102c8df1e6704d171a213143cfd001b036e44640567559692d8acc1a294b72b10d996ef SHA512 6da84b30b32fa70cdf77e6506b843b06c86c5a0ef8481fb2af4bc5f07699362c52285d516a5b2975553aa3aab14466cfd271a1ee809daa873fc5417e70623deb
DIST nwg-shell-0.5.7.tar.gz 289852 BLAKE2B d75ec6d01ee7c507fc8227ee0968fbd5f21e4bc94be9dcada342c320b6b62637d8d2112eabe442c880c9c38cb38fb175304d34c1911d6cf9adcb1141445c4624 SHA512 c1f2c098576ab52ac96d150f5d8648f9ff70ddafb8eea1793ded328d03233b7f650ace1fc92713748ca91c207bb69c1251a235bc75a6def0512e580010fe7730
diff --git a/gui-apps/nwg-shell/nwg-shell-0.5.18.ebuild b/gui-apps/nwg-shell/nwg-shell-0.5.18.ebuild
new file mode 100644
index 000000000..b531d0d56
--- /dev/null
+++ b/gui-apps/nwg-shell/nwg-shell-0.5.18.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+SRC_URI="https://github.com/nwg-piotr/nwg-shell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="meta-package for the nwg-shell project"
+HOMEPAGE="https://github.com/nwg-piotr/nwg-shell"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-misc/gopsuinfo
+ app-misc/nwg-look
+ gui-apps/azote
+ gui-apps/nwg-bar
+ gui-apps/nwg-displays
+ || ( gui-apps/nwg-dock gui-apps/nwg-dock-hyprland )
+ gui-apps/nwg-drawer
+ gui-apps/nwg-menu
+ gui-apps/nwg-panel
+ gui-apps/nwg-shell-config
+"
+DEPEND="${RDEPEND}"
+
+pkg_postinst() {
+ elog "To install nwg-shell for the current user, run"
+ elog "nwg-shell-installer -w (for sway) or"
+ elog "nwg-shell-installer -w -hypr (for hyprland)"
+}