aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2024-07-05 20:53:29 +0200
committerPascal Jäger <pascal.jaeger@leimstift.de>2024-07-05 20:55:16 +0200
commit627474457fa7a742f4bb40cc225231e36f47c509 (patch)
tree29c4fb58fda8f7f24a64e1c3a2f20c79c48e284f
parentgui-apps/nwg-drawer: drop 0.4.7 (diff)
downloadguru-627474457fa7a742f4bb40cc225231e36f47c509.tar.gz
guru-627474457fa7a742f4bb40cc225231e36f47c509.tar.bz2
guru-627474457fa7a742f4bb40cc225231e36f47c509.zip
gui-apps/nwg-shell: add 0.5.35
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
-rw-r--r--gui-apps/nwg-shell/Manifest1
-rw-r--r--gui-apps/nwg-shell/nwg-shell-0.5.35.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/gui-apps/nwg-shell/Manifest b/gui-apps/nwg-shell/Manifest
index 9596c33c3..91803a563 100644
--- a/gui-apps/nwg-shell/Manifest
+++ b/gui-apps/nwg-shell/Manifest
@@ -1,2 +1,3 @@
DIST nwg-shell-0.5.33.tar.gz 2181780 BLAKE2B 0d675bf7230d254e0accd1805329fad90b85f38e74e468a5cf8fa139d9c9fdc833353aa5514ba9c3b32a47afe25439c8c96fbc7e2af763a4db921b781b68a593 SHA512 ae4091faaee6dfb3f0f5f01ab5697ded6e4c508c15082b83bf024afec93d51e7fd165ad7780ea1fe88e6d630d3c1b9d2a6255f73484ffb1db969a38b6abf1d18
DIST nwg-shell-0.5.34.tar.gz 2181853 BLAKE2B e85f59a871d9b3e485e3f6ecfb84e1c87a00f9e4814386d3b8be83a15c8ce617ab3a09c2948763d8efd4278d9411c59ceae68aee010252113ee53ae8b891b29e SHA512 95face93d593c0a2c2e1e7631b00e67141c8dc2651248778773d3bbf4aa5b207952e5783a496e6a539dcca327d0ce795ca4d778c020000909dd568541cc0f258
+DIST nwg-shell-0.5.35.tar.gz 2181827 BLAKE2B cd2969e0deecee1f43bdf25218203cd86a4ce828c24ad3a931d26d191a003c47093c5e919f3bd27ae85f4899ddea316596b066227c7c1edb978a03aae7076ada SHA512 b9a9dea24d8d0b7d1eb77d69fd33a70868de49113a25d79be45411862375ef0968083738b3081496580661997c9793af66bfa09b622b0fab4b90ac68b6d8c04b
diff --git a/gui-apps/nwg-shell/nwg-shell-0.5.35.ebuild b/gui-apps/nwg-shell/nwg-shell-0.5.35.ebuild
new file mode 100644
index 000000000..b2a468557
--- /dev/null
+++ b/gui-apps/nwg-shell/nwg-shell-0.5.35.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="libraries an common functions for the nwg-shell project"
+HOMEPAGE="https://github.com/nwg-piotr/nwg-shell"
+SRC_URI="https://github.com/nwg-piotr/nwg-shell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ gui-apps/grim
+ gui-apps/swappy
+ gui-apps/slurp
+"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ default
+ dobin scripts/*
+}
+
+pkg_postinst() {
+ elog "To install nwg-shell for the current user, run"
+ elog "nwg-shell-installer -w (for sway) or"
+ elog "nwg-shell-installer -w -hypr (for hyprland)"
+}