aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2016-05-01 14:34:53 -0700
committerBrian Dolbec <dolsen@gentoo.org>2016-05-01 14:34:53 -0700
commitf461dd513967d322872b12b8ea059f941c0919f1 (patch)
tree6dc0eb902db94e0824bb187ab5b8f73a73bcece4
parentEAPI unsupported pkg test (diff)
downloadgen-b0rk-f461dd513967d322872b12b8ea059f941c0919f1.tar.gz
gen-b0rk-f461dd513967d322872b12b8ea059f941c0919f1.tar.bz2
gen-b0rk-f461dd513967d322872b12b8ea059f941c0919f1.zip
Ebuild invalid pkg
This package tests for an invalid package "no version"
-rw-r--r--ebuild-test/invalid/invalid.ebuild17
-rw-r--r--ebuild-test/invalid/metadata.xml26
-rw-r--r--profiles/categories1
3 files changed, 44 insertions, 0 deletions
diff --git a/ebuild-test/invalid/invalid.ebuild b/ebuild-test/invalid/invalid.ebuild
new file mode 100644
index 0000000..6f9af55
--- /dev/null
+++ b/ebuild-test/invalid/invalid.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Invalid name... missing version"
+HOMEPAGE="http://example.com"
+SRC_URI=""
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
diff --git a/ebuild-test/invalid/metadata.xml b/ebuild-test/invalid/metadata.xml
new file mode 100644
index 0000000..a698fa7
--- /dev/null
+++ b/ebuild-test/invalid/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!--
+# $Id$
+
+This is the example metadata file.
+The root element of this file is <pkgmetadata>. Within this element a
+number of subelements are allowed, the most common being maintainer.
+
+For a full description look at:
+https://devmanual.gentoo.org/ebuild-writing/misc-files/metadata/
+
+Before committing, please remove the comments from this file. They are
+not relevant for general metadata.xml files.
+-->
+<pkgmetadata>
+<maintainer type="person">
+ <email>exampledev@gentoo.org</email>
+ <description>Primary maintainer</description>
+</maintainer>
+<maintainer type="project">
+ <email>exampleproject@gentoo.org</email>
+ <name>Gentoo Example Project</name>
+</maintainer>
+<longdescription>Test for an invalid or missing version</longdescription>
+</pkgmetadata>
diff --git a/profiles/categories b/profiles/categories
index 8365ef7..6b6f015 100644
--- a/profiles/categories
+++ b/profiles/categories
@@ -1,5 +1,6 @@
deps-test
eapi-test
+ebuild-test
keywords-test
live-vcs
xml-test