aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2016-05-16 16:04:48 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2016-05-16 16:04:48 +0000
commiteedb07f60eb9606d496cc0da115c423614f02b51 (patch)
treec47ced3563a3ea80b7bf367f7d89b2b349c19089
parentebuild-test/upstream-workaround: new test (diff)
downloadgen-b0rk-eedb07f60eb9606d496cc0da115c423614f02b51.tar.gz
gen-b0rk-eedb07f60eb9606d496cc0da115c423614f02b51.tar.bz2
gen-b0rk-eedb07f60eb9606d496cc0da115c423614f02b51.zip
Add ebuild for testing missing patches.
Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
-rw-r--r--ebuild-test/missing-patches/Manifest1
-rw-r--r--ebuild-test/missing-patches/files/files-patch-1.patch0
-rw-r--r--ebuild-test/missing-patches/metadata.xml26
-rw-r--r--ebuild-test/missing-patches/missing-patches-0.ebuild18
4 files changed, 45 insertions, 0 deletions
diff --git a/ebuild-test/missing-patches/Manifest b/ebuild-test/missing-patches/Manifest
new file mode 100644
index 0000000..a7f6595
--- /dev/null
+++ b/ebuild-test/missing-patches/Manifest
@@ -0,0 +1 @@
+DIST missing-patches-0.tar.bz2 182 SHA256 473fdf9154af409f23c297c7355ff924247338ab004e2bd6bb1d9f7a74ad00fb SHA512 d896a8a2fe109cf017757a0a5098b644561ff62964b19d99434947b0fcbc38f80168d8189f4fc1975dcbba4b1b810e8f8a1aa7e3d086f679cb118339abe25b0e WHIRLPOOL 85a668e71c596164d57100b942d5fa274095e75dfaf42a91bdf6d500bdc80cdf4584718415809ec1500e59fbd05391b5f34419b61b8650774754fa24aab6d7e1
diff --git a/ebuild-test/missing-patches/files/files-patch-1.patch b/ebuild-test/missing-patches/files/files-patch-1.patch
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/ebuild-test/missing-patches/files/files-patch-1.patch
diff --git a/ebuild-test/missing-patches/metadata.xml b/ebuild-test/missing-patches/metadata.xml
new file mode 100644
index 0000000..da7c4a8
--- /dev/null
+++ b/ebuild-test/missing-patches/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!--
+# $Id$
+
+This is the example metadata file.
+The root element of this file is <pkgmetadata>. Within this element a
+number of subelements are allowed, the most common being maintainer.
+
+For a full description look at:
+https://devmanual.gentoo.org/ebuild-writing/misc-files/metadata/
+
+Before committing, please remove the comments from this file. They are
+not relevant for general metadata.xml files.
+-->
+<pkgmetadata>
+<maintainer type="person">
+ <email>exampledev@gentoo.org</email>
+ <description>Primary maintainer</description>
+</maintainer>
+<maintainer type="project">
+ <email>exampleproject@gentoo.org</email>
+ <name>Gentoo Example Project</name>
+</maintainer>
+<longdescription>Test for ???</longdescription>
+</pkgmetadata>
diff --git a/ebuild-test/missing-patches/missing-patches-0.ebuild b/ebuild-test/missing-patches/missing-patches-0.ebuild
new file mode 100644
index 0000000..d5e0376
--- /dev/null
+++ b/ebuild-test/missing-patches/missing-patches-0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Missing patches"
+HOMEPAGE="https://foo.example.org/"
+SRC_URI="https://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+DEPEND=""
+RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/files-patch-1.patch"
+ "${FILESDIR}/files-patch-2.patch"
+ "${S}/patch-1.patch"
+ "${S}/patch-2.patch"
+)