aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeather <Heather@live.ru>2016-04-29 12:51:20 +0400
committerHeather <Heather@live.ru>2016-04-29 12:51:20 +0400
commitc92b0809d7c7ed71883d90190d9856491c6b0741 (patch)
tree4a4c4382ba07fa40617d4a149021ac620b4494a5 /dev-lang
parentMerge pull request #188 from RulonZerkalo/mono-4.4.0.122 (diff)
downloaddotnet-c92b0809d7c7ed71883d90190d9856491c6b0741.tar.gz
dotnet-c92b0809d7c7ed71883d90190d9856491c6b0741.tar.bz2
dotnet-c92b0809d7c7ed71883d90190d9856491c6b0741.zip
dev-lang/mono: bump
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mono/Manifest1
-rw-r--r--dev-lang/mono/mono-4.4.0.148.ebuild120
2 files changed, 121 insertions, 0 deletions
diff --git a/dev-lang/mono/Manifest b/dev-lang/mono/Manifest
index 82709e6..b759e17 100644
--- a/dev-lang/mono/Manifest
+++ b/dev-lang/mono/Manifest
@@ -2,4 +2,5 @@ DIST mono-3.12.1.tar.bz2 73487974 SHA256 5d8cf153af2948c06bc9fbf5088f6834868e4db
DIST mono-4.2.2.30.tar.bz2 78365827 SHA256 57858cd033be9915d7abdc5158c1faae8fa05757c3b7117cab3d703aa696c56b SHA512 5aa93b362da84970310cc35bf02300718a20d2b508c263f45224d89f7aee84ead90c6fd7230ee2f17a2c02d480e3a8f7d2c9308cec0062a8f4c107f674a7c752 WHIRLPOOL fed4edbc5a724777bfe32edd4493c95904983e295c5c093f36231dfcdd9466daa8a21ed79c2686f8f0c6c5bbef8dafd88e82b3131e69e2d31e99fdc36de5aaf5
DIST mono-4.3.2.467.tar.bz2 84929059 SHA256 2949e06b7301a4d9315f622bff318b77f0dc5cdd7a0f9bc086239e5fdb0c87c5 SHA512 c767e0e1112754b2e8b754ef6e9dc1b2ee508b4aa22fa90ada9036c359680ab95216d01ea3c15690065b51df2ac58360d694d9f67fc3564b43fe47fd8a935a45 WHIRLPOOL 2b01c49e14981f536c24d2a95f2ce49e36d0c71f508ad784c18a7ba3b1aedf34016f2bde87587a6689aa3697eccbfe7f697cad37e25c6d85f851ab4b7406aa67
DIST mono-4.4.0.122.tar.bz2 84904723 SHA256 8d29386e5c97ae39a80c732dc854ecba92b24d8f70407ee34b4600820ce9f5b7 SHA512 264b3779fc94e40c44f8cc637169d7f3a6367ead75b932069bc0498d53c13ea62ef5711784d1bc0767b85e0cb04424b9eee0ce7ed10772076902b55210097a10 WHIRLPOOL 27c08e78d5f83a3e469c1d9449a5054174a6165490ae0f08433f8f70a971984d71e216f5c52a2a6ad59b6c28571b758ac1a60b8fd49d51469fb8dbaf278ed591
+DIST mono-4.4.0.148.tar.bz2 84897767 SHA256 38ad527608c26b2637472602d91d6af203dc4202be915e583fdc9e3a9252a5f3 SHA512 c1e0a7d589cc181fcfe36006879362ad0f5fca0d903fef723f7c4ed68dbd1eb2a7526b2e44c23f2b4c7b1cbcadeae6c7b004aab0643f09dc32640776892c3a22 WHIRLPOOL 9ada86d6026c0a139929a41b11e8849b7545f44be93ffa9c316a2877927d1883419bfb7f3aeb3b1dc593d6f9c0fe6e154e7e30285e70d25c75990c31ec704c85
DIST mono-4.4.0.40.tar.bz2 84877673 SHA256 803cd367562affb4150783e0b7dc7986f633ebcb61e6d733650a8485385e0fff SHA512 e9d2386a27316e5da03ac4943b60b436d51343a9bf04b924becd3c141726580fe74df373ade7b1061eaaab6c91a39a595aa95b84f132567f80af9a91da99eaf7 WHIRLPOOL 76e5545d8ffff92e1271b63c86ab0d703afaf9cf5685e4f8a9801700c84106037fcc34e1a9c91bce319779dc753a149162db212924996df2e843014fd1ad35ea
diff --git a/dev-lang/mono/mono-4.4.0.148.ebuild b/dev-lang/mono/mono-4.4.0.148.ebuild
new file mode 100644
index 0000000..be546cf
--- /dev/null
+++ b/dev-lang/mono/mono-4.4.0.148.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+AUTOTOOLS_PRUNE_LIBTOOL_FILES="all"
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils linux-info mono-env flag-o-matic pax-utils versionator
+
+DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
+HOMEPAGE="http://www.mono-project.com/Main_Page"
+SRC_URI="http://download.mono-project.com/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+
+IUSE="nls minimal pax_kernel xen doc"
+
+COMMONDEPEND="
+ !minimal? ( >=dev-dotnet/libgdiplus-2.10 )
+ ia64? ( sys-libs/libunwind )
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="${COMMONDEPEND}
+ || ( www-client/links www-client/lynx )
+"
+DEPEND="${COMMONDEPEND}
+ sys-devel/bc
+ virtual/yacc
+ pax_kernel? ( sys-apps/elfix )
+ !dev-lang/mono-basic
+"
+
+MAKEOPTS="${MAKEOPTS} -j1" #nowarn
+S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)"
+
+pkg_pretend() {
+ # https://github.com/gentoo/gentoo/blob/f200e625bda8de696a28338318c9005b69e34710/eclass/linux-info.eclass#L686
+ # If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling.
+ # See http://bugs.gentoo.org/261869 for more info."
+ CONFIG_CHECK="SYSVIPC"
+ use kernel_linux && check_extra_config
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ mono-env_pkg_setup
+}
+
+src_prepare() {
+ # we need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it don't
+ # get killed in the build proces when MPROTECT is enable. #286280
+ # RANDMMAP kill the build proces to #347365
+ # use paxmark.sh to get PT/XT logic #532244
+ if use pax_kernel ; then
+ ewarn "We are disabling MPROTECT on the mono binary."
+
+ # issue 9 : https://github.com/Heather/gentoo-dotnet/issues/9
+ sed '/exec "/ i\paxmark.sh -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
+ fi
+
+ # mono build system can fail otherwise
+ strip-flags
+
+ # Fix VB targets
+ # http://osdir.com/ml/general/2015-05/msg20808.html
+ #eapply "${FILESDIR}/add_missing_vb_portable_targets.patch"
+
+ # Fix build when sgen disabled
+ # https://bugzilla.xamarin.com/show_bug.cgi?id=32015
+ #eapply "${FILESDIR}/${PN}-4.0.2.5-fix-mono-dis-makefile-am-when-without-sgen.patch"
+
+ # TODO: update patch
+ # Fix atomic_add_i4 support for 32-bit ppc
+ # https://github.com/mono/mono/compare/f967c79926900343f399c75624deedaba460e544^...8f379f0c8f98493180b508b9e68b9aa76c0c5bdf
+ #epatch "${FILESDIR}/${PN}-4.0.2.5-fix-ppc-atomic-add-i4.patch"
+
+ # TODO: update patch
+ #epatch "${FILESDIR}/systemweb3.patch"
+ #epatch "${FILESDIR}/fix-for-GitExtensions-issue-2710-another-resolution.patch"
+ #epatch "${FILESDIR}/fix-for-bug36724.patch"
+
+ default_src_prepare
+ #eapply_user
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-silent-rules
+ $(use_with xen xen_opt)
+ --without-ikvm-native
+ --disable-dtrace
+ $(use_with doc mcs-docs)
+ $(use_enable nls)
+ )
+
+ default_src_configure
+}
+
+src_compile() {
+ default_src_compile
+}
+
+src_test() {
+ cd mcs/tests || die
+ emake check
+}
+
+src_install() {
+ default_src_install
+
+ # Remove files not respecting LDFLAGS and that we are not supposed to provide, see Fedora
+ # mono.spec and http://www.mail-archive.com/mono-devel-list@lists.ximian.com/msg24870.html
+ # for reference.
+ rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mscorlib.dll.so || die
+ rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mcs.exe.so || die
+}