aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsenShnurkov <ArsenShnurkov@users.noreply.github.com>2017-12-28 02:24:34 +0300
committerArsenShnurkov <ArsenShnurkov@users.noreply.github.com>2017-12-28 02:24:34 +0300
commit94d3a15171b8a1ce6ea2b0afa7e4d74bd5217b7d (patch)
tree5dbb1184f8195fea3046a5ff956a35c365772917 /dev-lang
parentmono-5.9.0.398 (experimental stuff) (diff)
downloaddotnet-94d3a15171b8a1ce6ea2b0afa7e4d74bd5217b7d.tar.gz
dotnet-94d3a15171b8a1ce6ea2b0afa7e4d74bd5217b7d.tar.bz2
dotnet-94d3a15171b8a1ce6ea2b0afa7e4d74bd5217b7d.zip
build with new jemalloc code (turned off)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mono/Manifest1
-rw-r--r--dev-lang/mono/files/try-catch.patch31
-rw-r--r--dev-lang/mono/mono-5.11.0.132_pre.ebuild114
3 files changed, 146 insertions, 0 deletions
diff --git a/dev-lang/mono/Manifest b/dev-lang/mono/Manifest
index b85105c..00c5414 100644
--- a/dev-lang/mono/Manifest
+++ b/dev-lang/mono/Manifest
@@ -1,4 +1,5 @@
DIST mono-5.0.1.1.tar.bz2 154477308 SHA256 48d6ae71d593cd01bf0f499de569359d45856cda325575e1bacb5fabaa7e9718 SHA512 de2a8a3580b8236bafdc7e6967d68da08bf2dc775bce5166aba6134c1b986ae7fc56b97743d5122de14bf8fe074d3508c07324735616439dea0913633ee817da WHIRLPOOL 21fa5f28ed85873d41b1d3a724e7a47c678a177a350a648bf148b6aa870f68caaf47da9ba139a0c3d4a71cc15416a086642a522676a542771e5142c757c9fea6
+DIST mono-5.11.0.132.tar.bz2 208457253 SHA256 e04847b69ebf5cc34779fd3cd50cf5a67befaa33a49deb209dcc8700e1b3ec1f SHA512 56058e5ad62a31b6e8748de94d1f416f18f3a85fd996b9c4560fc552b96e00cd3b326b8e98e3736eccc131f19e3525a5982fa4781d5d165d4d4f4f0f64cda689 WHIRLPOOL be0977ea7a60257aba7a9eca3fa1a8793b7f693ffa9c54354207b0d0966841f65e82a459dab5d4bf260d331783a96f50babd40d3d6df76748970a46e58db1981
DIST mono-5.2.0.196.tar.bz2 158175736 SHA256 731634b24c89680660fed1efd63a39ec6c052e519ae9a2dce61f875598329366 SHA512 9a767d3fa30ef2d96cce13767c5da5604443495071da475a1f1452916501f2b6a94c2a45dfeee49cc0423cfeee48640a28989ea5d61270fbd51cadd143dc425c WHIRLPOOL 85841722c311d5eb976213a18a771930bd67994706007f1ffa536c4380c877f2b7d422798f51a6567554eb93e81fff33477106bba534881fcd985076f8168fa6
DIST mono-5.2.0.224.tar.bz2 158434164 SHA256 03b8e463032bc425673dec844b35b4c669f5b99b0e45521195efb3741a9f5e94 SHA512 914ab11c892f6e59c1a89d92eb4b130a62ea606691820f9d9f48a2a68f7de3e593c233be071cd37ad5d817c5f5fda6892f89f1b0985fc44de97c1297300c706b WHIRLPOOL 3c16019246341dc1abcc98358bc977142ff35510c226a76d5069bce0cece4754c1f81ca176f1ad988aabebfd482a03b524267aa3136e0df144c703ba3bea6c6f
DIST mono-5.4.0.167.tar.bz2 199774651 SHA256 c2afe51b0fb074936a8e7eaee805c352f37cbf1093bb41c5345078f77d913ce0 SHA512 c55a0732baed323438491d3c5ac04446932ae85f5da3298d2123208aef493ae1531edfd12965886d45b3d09a7fa954482211bf6a3f0ac5ce9aa10694ec13fd48 WHIRLPOOL e8a47c43c61943f797dd58e25abc93ae4f46ed27434c64026818a734a1691c3b5ab2eeca4bbc36f1ae09c64e874fe78128b8bb8cadf1315015354f46a609c5b2
diff --git a/dev-lang/mono/files/try-catch.patch b/dev-lang/mono/files/try-catch.patch
new file mode 100644
index 0000000..051c72b
--- /dev/null
+++ b/dev-lang/mono/files/try-catch.patch
@@ -0,0 +1,31 @@
+diff -ur mono-5.9.0.398/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs mono-patched-5.9.0.398/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs
+--- mono-5.9.0.398/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs 2017-11-17 18:12:57.000000000 +0300
++++ mono-patched-5.9.0.398/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs 2017-12-06 06:24:45.067519852 +0300
+@@ -2810,14 +2810,21 @@
+
+ internal override object ClipboardRetrieve(IntPtr handle, int type, XplatUI.ClipboardToObject converter)
+ {
+- XConvertSelection(DisplayHandle, handle, (IntPtr)type, (IntPtr)type, FosterParent, IntPtr.Zero);
++ try
++ {
++ XConvertSelection(DisplayHandle, handle, (IntPtr)type, (IntPtr)type, FosterParent, IntPtr.Zero);
+
+- Clipboard.Retrieving = true;
+- while (Clipboard.Retrieving) {
+- UpdateMessageQueue(null, false);
+- }
++ Clipboard.Retrieving = true;
++ while (Clipboard.Retrieving) {
++ UpdateMessageQueue(null, false);
++ }
+
+- return Clipboard.Item;
++ return Clipboard.Item;
++ }
++ catch (Exception ex)
++ {
++ return null;
++ }
+ }
+
+ internal override void ClipboardStore (IntPtr handle, object obj, int type, XplatUI.ObjectToClipboard converter, bool copy)
diff --git a/dev-lang/mono/mono-5.11.0.132_pre.ebuild b/dev-lang/mono/mono-5.11.0.132_pre.ebuild
new file mode 100644
index 0000000..f054844
--- /dev/null
+++ b/dev-lang/mono/mono-5.11.0.132_pre.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+RESTRICT="mirror"
+SLOT="0"
+
+IUSE="nls minimal pax_kernel xen doc"
+
+inherit autotools eutils linux-info mono-env flag-o-matic pax-utils versionator multilib-minimal
+
+MY_PN="${PN}"
+MY_PV="$(get_version_component_range 1-4)"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
+HOMEPAGE="http://www.mono-project.com/Main_Page"
+LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
+
+SRC_URI="http://download.mono-project.com/sources/mono/nightly/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+COMMONDEPEND="
+ !minimal? ( >=dev-dotnet/libgdiplus-2.10 )
+ ia64? ( sys-libs/libunwind )
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="${COMMONDEPEND}
+ || ( www-client/links www-client/lynx )
+"
+DEPEND="${COMMONDEPEND}
+ sys-devel/bc
+ virtual/yacc
+ pax_kernel? ( sys-apps/elfix )
+ dev-util/cmake
+ !dev-lang/mono-basic
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.0.1.1-x86_32.patch
+ "${FILESDIR}"/try-catch.patch
+)
+
+pkg_pretend() {
+ linux-info_pkg_setup
+ if use kernel_linux; then
+ if linux_config_exists; then
+ linux_chkconfig_builtin SYSVIPC || die "SYSVIPC not enabled in the kernel"
+ else
+ # https://github.com/gentoo/gentoo/blob/f200e625bda8de696a28338318c9005b69e34710/eclass/linux-info.eclass#L686
+ ewarn "kernel config not found"
+ ewarn "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
+ ewarn "See http://bugs.gentoo.org/261869 for more info."
+ fi
+ fi
+}
+
+pkg_setup() {
+ mono-env_pkg_setup
+}
+
+src_prepare() {
+ # we need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it don't
+ # get killed in the build proces when MPROTECT is enable. #286280
+ # RANDMMAP kill the build proces to #347365
+ # use paxmark.sh to get PT/XT logic #532244
+ if use pax_kernel ; then
+ ewarn "We are disabling MPROTECT on the mono binary."
+
+ # issue 9 : https://github.com/Heather/gentoo-dotnet/issues/9
+ sed '/exec "/ i\paxmark.sh -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
+ fi
+
+ # mono build system can fail otherwise
+ strip-flags
+
+ #TODO: resolve problem with newer binutils
+ #bug: https://bugs.gentoo.org/show_bug.cgi?id=600664
+ #append-flags -fPIC
+
+ default
+ # PATCHES contains configure.ac patch
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-silent-rules
+ $(use_with xen xen_opt)
+ --without-ikvm-native
+ --disable-dtrace
+ $(use_with doc mcs-docs)
+ $(use_enable nls)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+ cd mcs/tests || die
+ emake check
+}
+
+multilib_src_install() {
+ default_src_install
+
+ # Remove files not respecting LDFLAGS and that we are not supposed to provide, see Fedora
+ # mono.spec and http://www.mail-archive.com/mono-devel-list@lists.ximian.com/msg24870.html
+ # for reference.
+ rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mscorlib.dll.so || die
+ rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mcs.exe.so || die
+}