aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2014-01-22 13:20:47 -0800
committerSteve Arnold <stephen.arnold42@gmail.com>2014-01-22 13:20:47 -0800
commit8d5b4d30b414fa6f07e2a9bd1567083b91e84818 (patch)
tree53be9ef39ebc94344f83f5d6c26c5ee9d921f18c /x11-proto
parentupdated xorg-server ebuild and set it to build the 1.15.99.900 commit (diff)
downloadarm-8d5b4d30b414fa6f07e2a9bd1567083b91e84818.tar.gz
arm-8d5b4d30b414fa6f07e2a9bd1567083b91e84818.tar.bz2
arm-8d5b4d30b414fa6f07e2a9bd1567083b91e84818.zip
added a couple more xorg git ebuilds
Diffstat (limited to 'x11-proto')
-rw-r--r--x11-proto/fontsproto/Manifest1
-rw-r--r--x11-proto/fontsproto/fontsproto-9999.ebuild29
-rw-r--r--x11-proto/xproto/Manifest1
-rw-r--r--x11-proto/xproto/xproto-9999.ebuild25
4 files changed, 56 insertions, 0 deletions
diff --git a/x11-proto/fontsproto/Manifest b/x11-proto/fontsproto/Manifest
new file mode 100644
index 0000000..29fae66
--- /dev/null
+++ b/x11-proto/fontsproto/Manifest
@@ -0,0 +1 @@
+EBUILD fontsproto-9999.ebuild 836 SHA256 cc4dc8367a4f7d6fc588cd7c83f48d0d64cd1b40af4560b6714ac0dc29d1bbb7 SHA512 a21267a3fcf91bb57a0091671863011c9a9ceb3513081bae2277b5fa56d8ac8e48072b67b79cb7c9f2bc85512282b554c499d611a9e522e7f7252ae31b5f8425 WHIRLPOOL fe43e6b3914797095c7a5c9704f567282ce5dd50ab86e88c53ce0ca8a2de4fffc7551b87b33c5bdc7b4e99bbde71759be5a8fe7f66be867d1a6eed920cd1ffd5
diff --git a/x11-proto/fontsproto/fontsproto-9999.ebuild b/x11-proto/fontsproto/fontsproto-9999.ebuild
new file mode 100644
index 0000000..700adf5
--- /dev/null
+++ b/x11-proto/fontsproto/fontsproto-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/fontsproto/fontsproto-2.1.2.ebuild,v 1.10 2013/02/21 18:44:37 zmedico Exp $
+
+EAPI=4
+
+XORG_DOC=doc
+inherit xorg-2
+
+DESCRIPTION="X.Org Fonts protocol headers"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+# xorg-server-9999 build fails against latest
+#EGIT_COMMIT="81e4d4ec53f1f3848ff269fe476c3a1d35d93aef"
+
+pkg_setup() {
+ xorg-2_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+}
diff --git a/x11-proto/xproto/Manifest b/x11-proto/xproto/Manifest
new file mode 100644
index 0000000..147bb46
--- /dev/null
+++ b/x11-proto/xproto/Manifest
@@ -0,0 +1 @@
+EBUILD xproto-9999.ebuild 799 SHA256 ca593c2c7a4bcf25c709ef8293803c5411148f3ad7c4c672aa576961c31efa2f SHA512 cd5701692351d9783e2e8306a50fdb127ab858c73a2d2e2ea83fa1e8027b170df3c6583826d84faa83603dad934401e20e4de2c18e9b64bfae6b0826805bf1d5 WHIRLPOOL b4855c3e225171217591ad179804a85db1158be096abe48b759af55c0570a88a247043172494956d33eef61d51ac738b8f779364a421f633760f1b2e1f1769ab
diff --git a/x11-proto/xproto/xproto-9999.ebuild b/x11-proto/xproto/xproto-9999.ebuild
new file mode 100644
index 0000000..92b7fb8
--- /dev/null
+++ b/x11-proto/xproto/xproto-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xproto/xproto-7.0.25.ebuild,v 1.1 2013/11/28 16:50:41 chithanh Exp $
+
+EAPI=5
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org xproto protocol headers"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-2_src_configure
+}