aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2017-04-13 19:34:34 -0700
committerSteve Arnold <nerdboy@gentoo.org>2017-04-13 19:34:34 -0700
commit52aece8f12dd4c142ffad15bd5549b5a79b3eacc (patch)
tree2b242b48f15b98be75ced084e68e60ac7026971c /x11-drivers
parentx11-base/xorg-server: sync git version and update depends (diff)
downloadarm-52aece8f12dd4c142ffad15bd5549b5a79b3eacc.tar.gz
arm-52aece8f12dd4c142ffad15bd5549b5a79b3eacc.tar.bz2
arm-52aece8f12dd4c142ffad15bd5549b5a79b3eacc.zip
x11-drivers/xf86-video-armada: add "version" to build against libetnaviv
* makes both gpu drivers but requires legacy libetnaviv (ie, not the current header-only version) Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-armada/files/xf86-video-armada-0.0.1-remove-Werror-flags.patch48
-rw-r--r--x11-drivers/xf86-video-armada/xf86-video-armada-0.0.1.ebuild44
-rw-r--r--x11-drivers/xf86-video-armada/xf86-video-armada-9999.ebuild26
3 files changed, 112 insertions, 6 deletions
diff --git a/x11-drivers/xf86-video-armada/files/xf86-video-armada-0.0.1-remove-Werror-flags.patch b/x11-drivers/xf86-video-armada/files/xf86-video-armada-0.0.1-remove-Werror-flags.patch
new file mode 100644
index 0000000..5d05c0d
--- /dev/null
+++ b/x11-drivers/xf86-video-armada/files/xf86-video-armada-0.0.1-remove-Werror-flags.patch
@@ -0,0 +1,48 @@
+diff --git a/common/Makefile.am b/common/Makefile.am
+index 1e794e4..6d3490e 100644
+--- a/common/Makefile.am
++++ b/common/Makefile.am
+@@ -14,7 +14,6 @@
+ # Turn off -Wshadow - Xorg headers seem to declare a lot of globals
+ # which can conflict - index, range, etc.
+ AM_CFLAGS = $(filter-out -Wnested-externs -Wcast-qual -Wredundant-decls \
+- -Werror=write-strings -Wshadow,$(CWARNFLAGS)) \
+ $(XORG_CFLAGS)
+
+ noinst_LTLIBRARIES = libcommon.la
+diff --git a/etnaviv/Makefile.am b/etnaviv/Makefile.am
+index 95e3775..3f197a7 100644
+--- a/etnaviv/Makefile.am
++++ b/etnaviv/Makefile.am
+@@ -14,7 +14,6 @@
+ # Turn off -Wshadow - Xorg headers seem to declare a lot of globals
+ # which can conflict - index, range, etc.
+ AM_CFLAGS = $(filter-out -Wnested-externs -Wcast-qual -Wredundant-decls \
+- -Werror=write-strings -Wshadow,$(CWARNFLAGS)) \
+ $(XORG_CFLAGS) $(ETNAVIV_CFLAGS) $(DRMARMADA_CFLAGS) $(UDEV_CFLAGS) \
+ -I$(top_srcdir)/src -I$(top_srcdir)/common
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 3afed38..75650c3 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -14,7 +14,6 @@
+ # Turn off -Wshadow - Xorg headers seem to declare a lot of globals
+ # which can conflict - index, range, etc.
+ AM_CFLAGS = $(filter-out -Wnested-externs -Wcast-qual -Wredundant-decls \
+- -Werror=write-strings -Wshadow,$(CWARNFLAGS)) \
+ $(XORG_CFLAGS) $(DRMARMADA_CFLAGS) $(UDEV_CFLAGS) \
+ -I$(top_srcdir)/common
+
+diff --git a/vivante/Makefile.am b/vivante/Makefile.am
+index 686dd85..1e6c66f 100644
+--- a/vivante/Makefile.am
++++ b/vivante/Makefile.am
+@@ -14,7 +14,6 @@
+ # Turn off -Wshadow - Xorg headers seem to declare a lot of globals
+ # which can conflict - index, range, etc.
+ AM_CFLAGS = $(filter-out -Wnested-externs -Wcast-qual -Wredundant-decls \
+- -Werror=write-strings -Wshadow,$(CWARNFLAGS)) \
+ $(XORG_CFLAGS) $(LIBGAL_CFLAGS) $(DRMARMADA_CFLAGS) $(UDEV_CFLAGS) \
+ -I$(top_srcdir)/src -I$(top_srcdir)/common
+
diff --git a/x11-drivers/xf86-video-armada/xf86-video-armada-0.0.1.ebuild b/x11-drivers/xf86-video-armada/xf86-video-armada-0.0.1.ebuild
new file mode 100644
index 0000000..9f3afbe
--- /dev/null
+++ b/x11-drivers/xf86-video-armada/xf86-video-armada-0.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+XORG_BASE_INDIVIDUAL_URI=""
+EGIT_REPO_URI="https://github.com/VCTLabs/xf86-video-armada"
+XORG_DRI="always"
+
+inherit autotools xorg-2 git-r3
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_BRANCH="devel"
+ KEYWORDS=""
+else
+ #EGIT_COMMIT="87e9fa065c8aa82715a2941ebb8d3af73b145263"
+ EGIT_COMMIT="a5cdb15c7e2552327de4a79be86044d18b4cdad8"
+ KEYWORDS="~arm"
+fi
+
+DESCRIPTION="Xorg graphics driver for KMS based systems with pluggable GPU backend"
+IUSE=""
+
+RDEPEND=">=x11-base/xorg-server-1.18"
+
+DEPEND="${RDEPEND}
+ x11-libs/libdrm-armada
+ x11-libs/libetnaviv
+"
+
+pkg_setup() {
+ xorg-2_pkg_setup
+
+ # note: vivante requires libGAL
+ XORG_CONFIGURE_OPTIONS=(
+ --disable-vivante
+ --enable-etnaviv
+ )
+}
+
+src_prepare() {
+ eautoreconf
+}
diff --git a/x11-drivers/xf86-video-armada/xf86-video-armada-9999.ebuild b/x11-drivers/xf86-video-armada/xf86-video-armada-9999.ebuild
index 594b819..f303831 100644
--- a/x11-drivers/xf86-video-armada/xf86-video-armada-9999.ebuild
+++ b/x11-drivers/xf86-video-armada/xf86-video-armada-9999.ebuild
@@ -8,18 +8,32 @@ XORG_BASE_INDIVIDUAL_URI=""
EGIT_REPO_URI="https://github.com/VCTLabs/xf86-video-armada"
XORG_DRI="always"
-inherit xorg-2
+inherit xorg-2 git-r3
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_BRANCH="devel"
+ KEYWORDS=""
+else
+ EGIT_COMMIT="87e9fa065c8aa82715a2941ebb8d3af73b145263"
+ KEYWORDS="~arm"
+fi
DESCRIPTION="Xorg graphics driver for KMS based systems with pluggable GPU backend"
-KEYWORDS="~arm"
+IUSE="+etnaviv"
-RDEPEND=">=x11-base/xorg-server-1.17"
+RDEPEND=">=x11-base/xorg-server-1.18"
DEPEND="${RDEPEND}
x11-libs/libdrm-armada
x11-libs/libetnaviv
"
-XORG_CONFIGURE_OPTIONS=(
- --disable-vivante
- --disable-etnaviv )
+pkg_setup() {
+ xorg-2_pkg_setup
+
+ # note: vivante requires libGAL
+ XORG_CONFIGURE_OPTIONS=(
+ --disable-vivante
+# $(use_enable etnaviv)
+ )
+}