aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2015-05-14 00:41:44 -0700
committerSteve Arnold <stephen.arnold42@gmail.com>2015-05-14 00:41:44 -0700
commit4ba627f63bf27fa51026ba1bd2b25025a9c983ef (patch)
treef25e1f62b921bb01f3268f102dde759c16f46da7 /net-libs
parentadjust for hardfloat without neon (tested on rpi) (diff)
downloadarm-4ba627f63bf27fa51026ba1bd2b25025a9c983ef.tar.gz
arm-4ba627f63bf27fa51026ba1bd2b25025a9c983ef.tar.bz2
arm-4ba627f63bf27fa51026ba1bd2b25025a9c983ef.zip
major cruft removal
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-1.11.90-gtk-docize-fix.patch10
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-1.6.1-darwin-quartz.patch67
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-1.7.90-test_garbage_collection.patch18
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-2.2.2-unittests-build.patch45
4 files changed, 0 insertions, 140 deletions
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-1.11.90-gtk-docize-fix.patch b/net-libs/webkit-gtk/files/webkit-gtk-1.11.90-gtk-docize-fix.patch
deleted file mode 100644
index 8f56ab2..0000000
--- a/net-libs/webkit-gtk/files/webkit-gtk-1.11.90-gtk-docize-fix.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.ac.old 2013-03-02 09:22:53.791750644 +0200
-+++ configure.ac 2013-03-02 09:24:56.725213764 +0200
-@@ -24,6 +24,7 @@
- m4_include([Source/autotools/SetupLibtool.m4])
- m4_include([Source/autotools/ReadCommandLineArguments.m4])
- m4_include([Source/autotools/FindDependencies.m4])
-+GTK_DOC_CHECK([1.10])
- m4_include([Source/autotools/SetupCompilerFlags.m4])
- m4_include([Source/autotools/SetupAutoconfHeader.m4])
-
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-1.6.1-darwin-quartz.patch b/net-libs/webkit-gtk/files/webkit-gtk-1.6.1-darwin-quartz.patch
deleted file mode 100644
index 5ad357e..0000000
--- a/net-libs/webkit-gtk/files/webkit-gtk-1.6.1-darwin-quartz.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-Original from:
-http://trac.macports.org/browser/trunk/dports/www/webkit-gtk/files/patch-quartz-WebCore-plugins-gtk-gtkxtbin.c.diff?format=txt
-http://trac.macports.org/browser/trunk/dports/www/webkit-gtk/files/patch-quartz-WebCore-plugins-gtk-PluginViewGtk.cpp.diff?format=txt
-
-Adapted for 1.6.1
-
---- Source/WebCore/plugins/gtk/PluginViewGtk.cpp
-+++ Source/WebCore/plugins/gtk/PluginViewGtk.cpp
-@@ -70,6 +70,8 @@
- #endif
- #include <gtk/gtk.h>
-
-+#undef XP_UNIX
-+
- #if defined(XP_UNIX)
- #include "RefPtrCairo.h"
- #include "gtk2xtbin.h"
-@@ -439,9 +441,9 @@
- event->setDefaultHandled();
- }
-
--#if defined(XP_UNIX)
- void PluginView::handleFocusInEvent()
- {
-+#if defined(XP_UNIX)
- if (!m_isStarted || m_status != PluginStatusLoadedSuccessfully)
- return;
-
-@@ -454,10 +456,12 @@
- event.detail = NotifyDetailNone;
-
- dispatchNPEvent(npEvent);
-+#endif
- }
-
- void PluginView::handleFocusOutEvent()
- {
-+#if defined(XP_UNIX)
- if (!m_isStarted || m_status != PluginStatusLoadedSuccessfully)
- return;
-
-@@ -470,8 +474,8 @@
- event.detail = NotifyDetailNone;
-
- dispatchNPEvent(npEvent);
--}
- #endif
-+}
-
- void PluginView::setParent(ScrollView* parent)
- {
---- Source/WebCore/plugins/gtk/gtk2xtbin.c
-+++ Source/WebCore/plugins/gtk/gtk2xtbin.c
-@@ -41,7 +41,7 @@
- * The GtkXtBin widget allows for Xt toolkit code to be used
- * inside a GTK application.
- */
--
-+#if 0
- #include "GtkVersioning.h"
- #include "xembed.h"
- #include "gtk2xtbin.h"
-@@ -966,3 +966,4 @@
-
- return;
- }
-+#endif
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-1.7.90-test_garbage_collection.patch b/net-libs/webkit-gtk/files/webkit-gtk-1.7.90-test_garbage_collection.patch
deleted file mode 100644
index 577c249..0000000
--- a/net-libs/webkit-gtk/files/webkit-gtk-1.7.90-test_garbage_collection.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Garbage collection test fails intermittently if icedtea browser plugin is
-installed.
-
---- a/Source/WebKit/gtk/tests/testdomdocument.c
-+++ b/Source/WebKit/gtk/tests/testdomdocument.c
-@@ -353,12 +353,6 @@
- test_dom_document_get_links,
- dom_document_fixture_teardown);
-
-- g_test_add("/webkit/domdocument/test_garbage_collection",
-- DomDocumentFixture, HTML_DOCUMENT_LINKS,
-- dom_document_fixture_setup,
-- test_dom_document_garbage_collection,
-- dom_document_fixture_teardown);
--
- return g_test_run();
- }
-
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.2.2-unittests-build.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.2.2-unittests-build.patch
deleted file mode 100644
index 14fa30f..0000000
--- a/net-libs/webkit-gtk/files/webkit-gtk-2.2.2-unittests-build.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From: Gilles Dartiguelongue <eva@gentoo.org>
-Date: Wed, 27 Nov 2013 23:36:41 +0100
-Subject: [PATCH] Build unittests on demand
-
---- a/GNUmakefile.am 2013-11-27 23:52:56.148735433 +0100
-+++ b/GNUmakefile.am 2013-11-27 23:51:25.551590806 +0100
-@@ -51,6 +51,7 @@
- # Libraries and support components
- bin_PROGRAMS :=
- noinst_PROGRAMS :=
-+check_PROGRAMS :=
- libexec_PROGRAMS :=
- noinst_DATA :=
- noinst_HEADERS :=
---- a/Source/WebKit/gtk/GNUmakefile.am
-+++ b/Source/WebKit/gtk/GNUmakefile.am
-@@ -446,7 +446,7 @@ webkit_tests_ldflags = \
- -no-fast-install
-
- if ENABLE_WEBKIT1
--noinst_PROGRAMS += \
-+check_PROGRAMS += \
- Programs/unittests/testapplicationcache \
- Programs/unittests/testcontextmenu \
- Programs/unittests/testdomdocument \
---- a/Source/WebKit2/UIProcess/API/gtk/tests/GNUmakefile.am
-+++ b/Source/WebKit2/UIProcess/API/gtk/tests/GNUmakefile.am
-@@ -25,12 +25,12 @@ TEST_PROGS += \
- Programs/WebKit2APITests/TestWebKitWebViewGroup \
- Programs/WebKit2APITests/TestWebViewEditor
-
--noinst_PROGRAMS += $(TEST_PROGS)
-+check_PROGRAMS += $(TEST_PROGS)
-
- if HAVE_ATSPI2
- TEST_PROGS += Programs/WebKit2APITests/TestWebKitAccessibility
-
--noinst_PROGRAMS += Programs/WebKit2APITests/AccessibilityTestServer
-+check_PROGRAMS += Programs/WebKit2APITests/AccessibilityTestServer
- endif
-
- webkit2_tests_cppflags = \
---
-1.8.3.2
-