aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2015-08-20 09:21:27 -0700
committerSteve Arnold <stephen.arnold42@gmail.com>2015-08-20 09:21:27 -0700
commit141f8a142b8626b52d8db491a1dbf021e4d466a4 (patch)
tree12bd552d5e2e33acaafe3999ecb2a77ac4c6baa3 /dev-libs
parentadded arch-independent fstrim shell script daemon (diff)
downloadarm-141f8a142b8626b52d8db491a1dbf021e4d466a4.tar.gz
arm-141f8a142b8626b52d8db491a1dbf021e4d466a4.tar.bz2
arm-141f8a142b8626b52d8db491a1dbf021e4d466a4.zip
arm fixes and config options for GMP
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/gmp/Manifest2
-rw-r--r--dev-libs/gmp/gmp-6.0.0a.ebuild138
-rw-r--r--dev-libs/libinput/Manifest2
-rw-r--r--dev-libs/libinput/libinput-0.7.0.ebuild48
-rw-r--r--dev-libs/weston/Manifest1
-rw-r--r--dev-libs/weston/files/README.gentoo9
-rw-r--r--dev-libs/weston/weston-1.7.0.ebuild170
7 files changed, 370 insertions, 0 deletions
diff --git a/dev-libs/gmp/Manifest b/dev-libs/gmp/Manifest
new file mode 100644
index 0000000..5369034
--- /dev/null
+++ b/dev-libs/gmp/Manifest
@@ -0,0 +1,2 @@
+DIST gmp-6.0.0a.tar.xz 1904112 SHA256 9156d32edac6955bc53b0218f5f3763facb890b73a835d5e1b901dcf8eb8b764 SHA512 50368f4368b244b442438ce1768cf0f1166e490d1bafb8feda1ffc90fea3807e7328f30f3faa861799e4f5ff6e3113049ca3231b2f48571e4583fc3d60441816 WHIRLPOOL 81639a9d433ce9ccb26527af309c7c41437bb3463e5986cce3b35f81b527068a2304ec3287e660454f850dedab61463a077f49d4ea2b7ee87eec94b15730c394
+DIST gmp-man-6.0.0a.pdf 1187496 SHA256 b38ed1d760b20c01b734b65380ab667373fa48d8203f762a434cd3f326c67a38 SHA512 528972502d65d23b58c47a594a628e648f11cc027bd0894a39b8f892bb421ceabb7f35640a9eede21cea791f5f597ed4661a1f73444c56a6fb31fa6e362d96c2 WHIRLPOOL e6c4eb3a9adc82496a1872223ceb153e05c3aabd2323aeb38064739a5200eb8fc24fa3bb96f5fb1e632cc90a2576bd3966bae3c7a7a0c750ca56faeb30837eea
diff --git a/dev-libs/gmp/gmp-6.0.0a.ebuild b/dev-libs/gmp/gmp-6.0.0a.ebuild
new file mode 100644
index 0000000..14f98cc
--- /dev/null
+++ b/dev-libs/gmp/gmp-6.0.0a.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+inherit flag-o-matic eutils libtool toolchain-funcs multilib-minimal
+
+MY_PV=${PV/_p*}
+MY_P=${PN}-${MY_PV}
+PLEVEL=${PV/*p}
+DESCRIPTION="Library for arithmetic on arbitrary precision integers, rational numbers, and floating-point numbers"
+HOMEPAGE="http://gmplib.org/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.xz
+ ftp://ftp.gmplib.org/pub/${MY_P}/${MY_P}.tar.xz
+ doc? ( http://gmplib.org/${PN}-man-${MY_PV}.pdf )"
+
+LICENSE="|| ( LGPL-3+ GPL-2+ )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="+asm assert doc cxx fat pgo pic static-libs"
+
+DEPEND="sys-devel/m4
+ app-arch/xz-utils"
+RDEPEND="abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20131008-r1
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+)"
+
+S=${WORKDIR}/${MY_P%a}
+
+DOCS=( AUTHORS ChangeLog NEWS README doc/configuration doc/isa_abi_headache )
+HTML_DOCS=( doc )
+MULTILIB_WRAPPED_HEADERS=( /usr/include/gmp.h )
+
+src_prepare() {
+ [[ -d ${FILESDIR}/${PV} ]] && EPATCH_SUFFIX="diff" EPATCH_FORCE="yes" epatch "${FILESDIR}"/${PV}
+
+ # note: we cannot run autotools here as gcc depends on this package
+ elibtoolize
+
+ # GMP uses the "ABI" env var during configure as does Gentoo (econf).
+ # So, to avoid patching the source constantly, wrap things up.
+ mv configure configure.wrapped || die
+ cat <<-\EOF > configure
+ #!/bin/sh
+ exec env ABI="$GMPABI" "$0.wrapped" "$@"
+ EOF
+ chmod a+rx configure
+
+ # fails on arm
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ # Because of our 32-bit userland, 1.0 is the only HPPA ABI that works
+ # http://gmplib.org/manual/ABI-and-ISA.html#ABI-and-ISA (bug #344613)
+ if [[ ${CHOST} == hppa2.0-* ]] ; then
+ export GMPABI="1.0"
+ fi
+
+ # ABI mappings (needs all architectures supported)
+ case ${ABI} in
+ 32|x86) GMPABI=32;;
+ 64|amd64|n64) GMPABI=64;;
+ [onx]32) GMPABI=${ABI};;
+ esac
+ export GMPABI
+
+ local my_conf=""
+ if [[ ${CHOST} == armv* ]] ; then
+ #export gmp_cv_asm_underscore=yes
+ if use pic ; then
+ # pic should really be use_masked on arm
+ my_conf="--with-pic=no"
+ eerror "-fPIC not allowed on arm ABI!"
+ eerror "Please disable pic use flag to proceed."
+ fi
+ else
+ use pic && my_conf="--with-pic=yes"
+ fi
+ ##append-ldflags "-lrt"
+
+ tc-export CC
+ ECONF_SOURCE="${S}" econf ${my_conf} \
+ --localstatedir=/var/state/gmp \
+ --enable-shared \
+ $(use_enable asm assembly) \
+ $(use_enable assert) \
+ $(use_enable cxx) \
+ $(use_enable fat) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ emake
+
+ if use pgo ; then
+ LIBS="-static ${S}/.libs/libgmp.a ${S}/tune/.libs/libspeed.a" \
+ emake -j1 -C tune tuneup
+ ebegin "Trying to generate tuned data"
+ ./tune/tuneup | tee gmp.mparam.h.new
+ if eend $(( 0 + ${PIPESTATUS[*]/#/+} )) ; then
+ mv gmp.mparam.h.new gmp-mparam.h || die
+ emake clean
+ emake
+ fi
+ fi
+}
+
+multilib_src_test() {
+ emake check
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ # should be a standalone lib
+ rm -f "${D}"/usr/$(get_libdir)/libgmp.la
+ # this requires libgmp
+ local la="${D}/usr/$(get_libdir)/libgmpxx.la"
+ use static-libs \
+ && sed -i 's:/[^ ]*/libgmp.la:-lgmp:' "${la}" \
+ || rm -f "${la}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ use doc && cp "${DISTDIR}"/gmp-man-${MY_PV}.pdf "${D}"/usr/share/doc/${PF}/
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/libgmp.so.3
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/libgmp.so.3
+}
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
new file mode 100644
index 0000000..88f1a60
--- /dev/null
+++ b/dev-libs/libinput/Manifest
@@ -0,0 +1,2 @@
+DIST libinput-0.7.0.tar.xz 440228 SHA256 129f485afe5e4a9394641293991c97cb99f5f3338340d0d65b704ff463d1579e SHA512 0e03ab7ca98c4574997742b7d8912000fb176d7a3e2c381b7e63139f78455374f8f38284e226fe443d5a524f34be8995317b91fc0190795a97b10af060423b77 WHIRLPOOL 664510fc33cb718b56600553332bb3eb587b3f4a40f81d4a80dd218882aba204522bcbbfab98f3ae0c6447d3a39cc98b9d88aea5f8e3c21da0803b93d64ad321
+EBUILD libinput-0.7.0.ebuild 1045 SHA256 57da33055f4a6ec9e40f8f4ee5b3ad1d5481d53fafd316ec2be0af6e3e8d597e SHA512 4603dd6e2e13f40493fd524d31cde6a7d18aa1954ebeb6889a76b0236fe2fc7ab7440753bc82a8af111fa7566450286ea680366d378f89eecc0ae222e7d64a8f WHIRLPOOL c06ef2d6a4305aad4fd9751a5d83a54f659895bc21e31adafb8c61d299d60be49c61dc5c0c6ef31bbfa08c3b41f63280e07c85eeaf1f51d87f8c213312bc3797
diff --git a/dev-libs/libinput/libinput-0.7.0.ebuild b/dev-libs/libinput/libinput-0.7.0.ebuild
new file mode 100644
index 0000000..211ec45
--- /dev/null
+++ b/dev-libs/libinput/libinput-0.7.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+# License appears to be a variant of libtiff
+LICENSE="libtiff"
+SLOT="0/5"
+KEYWORDS="~amd64 ~arm"
+IUSE="test"
+
+RDEPEND="
+ >=dev-libs/libevdev-0.4
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-libs/check-0.9.10 )
+"
+# tests can even use: dev-util/valgrind
+
+src_prepare() {
+ # Doc handling in kinda strange but everything
+ # is available in the tarball already.
+ sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ econf \
+ --disable-event-gui \
+ $(use_enable test tests)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc -r doc/html
+ prune_libtool_files
+}
diff --git a/dev-libs/weston/Manifest b/dev-libs/weston/Manifest
new file mode 100644
index 0000000..f208172
--- /dev/null
+++ b/dev-libs/weston/Manifest
@@ -0,0 +1 @@
+DIST weston-1.7.0.tar.xz 1286904 SHA256 1c4511945f3f476c24af712e82a7b500ae91a99cbc0fe2e381da1449125166cd SHA512 2ba9c7cfd2a18354af8996bf8d78bbccd12bff1ee99102d5057758cdc54311632f7e7583ffcb075efb75e702a8fa210ea0c4f0f8bb8b18e9df39a9db77d03d19 WHIRLPOOL 48ee5e4b8676cc84fbeef019034b9961fe1be51f31af11d3df24ba1d5d446133b747ac1494ef080647d8b845492125fbb453a037d0b552b43a5167bbba8c36aa
diff --git a/dev-libs/weston/files/README.gentoo b/dev-libs/weston/files/README.gentoo
new file mode 100644
index 0000000..ed8c5c3
--- /dev/null
+++ b/dev-libs/weston/files/README.gentoo
@@ -0,0 +1,9 @@
+For running Weston you need to have $XDG_RUNTIME_DIR in your environment,
+directory must exist and have correct permissions. If you are not using systemd,
+it will not be created automatically, you can create it using your shell,
+add these lines to ~/.bash_profile:
+
+# wayland
+export XDG_RUNTIME_DIR=/tmp/.runtime-${USER}
+mkdir -p "${XDG_RUNTIME_DIR}"
+chmod 0700 "${XDG_RUNTIME_DIR}"
diff --git a/dev-libs/weston/weston-1.7.0.ebuild b/dev-libs/weston/weston-1.7.0.ebuild
new file mode 100644
index 0000000..072358a
--- /dev/null
+++ b/dev-libs/weston/weston-1.7.0.ebuild
@@ -0,0 +1,170 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/wayland/${PN}"
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+fi
+VIRTUALX_REQUIRED="test"
+RESTRICT="test"
+
+inherit autotools readme.gentoo toolchain-funcs virtualx $GIT_ECLASS
+
+DESCRIPTION="Wayland reference compositor"
+HOMEPAGE="http://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+else
+ SRC_URI="http://wayland.freedesktop.org/releases/${P}.tar.xz"
+fi
+
+LICENSE="MIT CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~arm-linux"
+IUSE="colord dbus +drm +egl editor examples fbdev gles2 headless ivi +opengl rdp +resize-optimization rpi +launch screen-sharing static-libs +suid systemd test unwind wayland-compositor +X xwayland"
+
+REQUIRED_USE="
+ drm? ( egl )
+ egl? ( !gles2 !opengl )
+ gles2? ( !opengl )
+ screen-sharing? ( rdp )
+ test? ( X )
+ wayland-compositor? ( egl )
+"
+
+RDEPEND="
+ >=dev-libs/libinput-0.8.0
+ >=dev-libs/wayland-1.7.0
+ media-libs/lcms:2
+ media-libs/libpng:0=
+ media-libs/libwebp:0=
+ virtual/jpeg
+ >=x11-libs/cairo-1.11.3[gles2(-)?,opengl?]
+ >=x11-libs/libdrm-2.4.30
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ x11-misc/xkeyboard-config
+ fbdev? (
+ >=sys-libs/mtdev-1.1.0
+ >=virtual/udev-136
+ )
+ colord? ( >=x11-misc/colord-0.1.27 )
+ dbus? ( sys-apps/dbus )
+ drm? (
+ media-libs/mesa[gbm]
+ >=sys-libs/mtdev-1.1.0
+ >=virtual/udev-136
+ )
+ egl? (
+ media-libs/glu
+ media-libs/mesa[gles2,wayland]
+ )
+ editor? ( x11-libs/pango )
+ gles2? (
+ media-libs/mesa[gles2,wayland]
+ )
+ opengl? (
+ media-libs/mesa[wayland]
+ )
+ rdp? ( >=net-misc/freerdp-1.1.0_beta1_p20130710 )
+ rpi? (
+ >=sys-libs/mtdev-1.1.0
+ >=virtual/udev-136
+ )
+ systemd? (
+ sys-auth/pambase[systemd]
+ sys-apps/systemd[pam]
+ )
+ launch? ( sys-auth/pambase )
+ unwind? ( sys-libs/libunwind )
+ X? (
+ x11-libs/libxcb
+ x11-libs/libX11
+ )
+ xwayland? (
+ x11-base/xorg-server[wayland]
+ x11-libs/cairo[xcb]
+ x11-libs/libxcb
+ x11-libs/libXcursor
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ if useq gles2 || useq opengl && { -z $I_KNOW_WHAT_I_AM_DOING ; } ; then
+ eerror "You probably don't want to enable gles2 or opengl here or"
+ eerror "cairo since they are slower and more problematic. Please"
+ eerror "disable the above USE flags or set the env variable"
+ eerror "I_KNOW_WHAT_I_AM_DOING to a value. You have been warned..."
+ die "Bad USE flag combination!"
+ fi
+}
+
+src_prepare() {
+ if [[ ${PV} = 9999* ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myconf
+ if use examples || use gles2 || use test; then
+ myconf="--enable-simple-clients
+ $(use_enable egl simple-egl-clients)"
+ else
+ myconf="--disable-simple-clients
+ --disable-simple-egl-clients"
+ fi
+
+ if use gles2 && -n $I_KNOW_WHAT_I_AM_DOING ; then
+ myconf+=" --with-cairo=glesv2"
+ elif use opengl && -n $I_KNOW_WHAT_I_AM_DOING ; then
+ myconf+=" --with-cairo=gl"
+ else
+ myconf+=" --with-cairo=image"
+ fi
+
+ econf \
+ $(use_enable examples demo-clients-install) \
+ $(use_enable fbdev fbdev-compositor) \
+ $(use_enable dbus) \
+ $(use_enable drm drm-compositor) \
+ $(use_enable headless headless-compositor) \
+ $(use_enable ivi ivi-shell) \
+ $(use_enable rdp rdp-compositor) \
+ $(use_enable rpi rpi-compositor) \
+ $(use_enable wayland-compositor) \
+ $(use_enable X x11-compositor) \
+ $(use_enable launch weston-launch) \
+ $(use_enable colord) \
+ $(use_enable egl) \
+ $(use_enable unwind libunwind) \
+ $(use_enable resize-optimization) \
+ $(use_enable screen-sharing) \
+ $(use_enable suid setuid-install) \
+ $(use_enable xwayland) \
+ $(use_enable xwayland xwayland-test) \
+ ${myconf}
+}
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ cd "${BUILD_DIR}" || die
+ Xemake check
+}
+
+src_install() {
+ default
+
+ readme.gentoo_src_install
+}