aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2017-04-13 19:33:22 -0700
committerSteve Arnold <nerdboy@gentoo.org>2017-04-13 19:33:22 -0700
commita3834d17cde2da67c166e0f9fc664cd662a4664a (patch)
tree06ec5d3fd0c0ec8f606eb0318b034c0c3ce781e8
parentx11-base/xorg-drivers: updates for foss graphics (diff)
downloadarm-a3834d17cde2da67c166e0f9fc664cd662a4664a.tar.gz
arm-a3834d17cde2da67c166e0f9fc664cd662a4664a.tar.bz2
arm-a3834d17cde2da67c166e0f9fc664cd662a4664a.zip
x11-base/xorg-server: sync git version and update depends
Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
-rw-r--r--x11-base/xorg-server/files/xorg-server-1.18-support-multiple-Files-sections.patch53
-rw-r--r--x11-base/xorg-server/files/xorg-server-1.18-sysmacros.patch59
-rw-r--r--x11-base/xorg-server/xorg-server-1.17.2-r1.ebuild4
-rw-r--r--x11-base/xorg-server/xorg-server-9999.ebuild44
4 files changed, 133 insertions, 27 deletions
diff --git a/x11-base/xorg-server/files/xorg-server-1.18-support-multiple-Files-sections.patch b/x11-base/xorg-server/files/xorg-server-1.18-support-multiple-Files-sections.patch
new file mode 100644
index 0000000..0a61145
--- /dev/null
+++ b/x11-base/xorg-server/files/xorg-server-1.18-support-multiple-Files-sections.patch
@@ -0,0 +1,53 @@
+See http://lists.x.org/archives/xorg-devel/2015-February/045755.html
+
+diff --git a/hw/xfree86/parser/Files.c b/hw/xfree86/parser/Files.c
+index 849bf92..5cc3ec7 100644
+--- a/hw/xfree86/parser/Files.c
++++ b/hw/xfree86/parser/Files.c
+@@ -76,14 +76,18 @@ static xf86ConfigSymTabRec FilesTab[] = {
+ #define CLEANUP xf86freeFiles
+
+ XF86ConfFilesPtr
+-xf86parseFilesSection(void)
++xf86parseFilesSection(XF86ConfFilesPtr ptr)
+ {
+ int i, j;
+ int k, l;
+ char *str;
+ int token;
+
+- parsePrologue(XF86ConfFilesPtr, XF86ConfFilesRec)
++ if (!ptr) {
++ if( (ptr=calloc(1,sizeof(XF86ConfFilesRec))) == NULL ) {
++ return NULL;
++ }
++ }
+
+ while ((token = xf86getToken(FilesTab)) != ENDSECTION) {
+ switch (token) {
+diff --git a/hw/xfree86/parser/configProcs.h b/hw/xfree86/parser/configProcs.h
+index 171f8e8..e8199fe 100644
+--- a/hw/xfree86/parser/configProcs.h
++++ b/hw/xfree86/parser/configProcs.h
+@@ -36,7 +36,7 @@ void xf86freeDeviceList(XF86ConfDevicePtr ptr);
+ int xf86validateDevice(XF86ConfigPtr p);
+
+ /* Files.c */
+-XF86ConfFilesPtr xf86parseFilesSection(void);
++XF86ConfFilesPtr xf86parseFilesSection(XF86ConfFilesPtr ptr);
+ void xf86printFileSection(FILE * cf, XF86ConfFilesPtr ptr);
+ void xf86freeFiles(XF86ConfFilesPtr p);
+
+diff --git a/hw/xfree86/parser/read.c b/hw/xfree86/parser/read.c
+index 327c02a..e0d6139 100644
+--- a/hw/xfree86/parser/read.c
++++ b/hw/xfree86/parser/read.c
+@@ -110,7 +110,7 @@ xf86readConfigFile(void)
+ if (xf86nameCompare(xf86_lex_val.str, "files") == 0) {
+ free(xf86_lex_val.str);
+ xf86_lex_val.str = NULL;
+- HANDLE_RETURN(conf_files, xf86parseFilesSection());
++ HANDLE_RETURN(conf_files, xf86parseFilesSection(ptr->conf_files));
+ }
+ else if (xf86nameCompare(xf86_lex_val.str, "serverflags") == 0) {
+ free(xf86_lex_val.str);
diff --git a/x11-base/xorg-server/files/xorg-server-1.18-sysmacros.patch b/x11-base/xorg-server/files/xorg-server-1.18-sysmacros.patch
new file mode 100644
index 0000000..5a3dea3
--- /dev/null
+++ b/x11-base/xorg-server/files/xorg-server-1.18-sysmacros.patch
@@ -0,0 +1,59 @@
+From 1df7e4f5c1090631ff6584176f7d1370d08bc15e Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <petr.pisar@atlas.cz>
+Date: Sat, 16 Apr 2016 13:04:59 +0200
+Subject: [PATCH] Include sys/sysmacros.h for major(3)
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+GNU major(3) manual page prescribes <sys/types.h>, but that does not work with
+sys-libs/glibc-2.23-r1.
+
+https://bugs.gentoo.org/show_bug.cgi?id=580044
+Signed-off-by: Petr Písař <petr.pisar@atlas.cz>
+---
+ config/udev.c | 1 +
+ hw/xfree86/common/xf86Xinput.c | 2 ++
+ hw/xfree86/os-support/linux/lnx_init.c | 1 +
+ 3 files changed, 4 insertions(+)
+
+diff --git a/config/udev.c b/config/udev.c
+index 28c2658..62908f4 100644
+--- a/config/udev.c
++++ b/config/udev.c
+@@ -30,6 +30,7 @@
+ #include <libudev.h>
+ #include <ctype.h>
+ #include <unistd.h>
++#include <sys/sysmacros.h>
+
+ #include "input.h"
+ #include "inputstr.h"
+diff --git a/hw/xfree86/common/xf86Xinput.c b/hw/xfree86/common/xf86Xinput.c
+index c56a2b9..d33c165 100644
+--- a/hw/xfree86/common/xf86Xinput.c
++++ b/hw/xfree86/common/xf86Xinput.c
+@@ -86,6 +86,8 @@
+ #include <unistd.h>
+ #ifdef HAVE_SYS_MKDEV_H
+ #include <sys/mkdev.h> /* for major() & minor() on Solaris */
++#else
++#include <sys/sysmacros.h>
+ #endif
+
+ #include "mi.h"
+diff --git a/hw/xfree86/os-support/linux/lnx_init.c b/hw/xfree86/os-support/linux/lnx_init.c
+index 1ed213c..6caf531 100644
+--- a/hw/xfree86/os-support/linux/lnx_init.c
++++ b/hw/xfree86/os-support/linux/lnx_init.c
+@@ -38,6 +38,7 @@
+ #include "xf86_OSlib.h"
+
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+
+ #ifndef K_OFF
+ #define K_OFF 0x4
+--
+2.8.1
+
diff --git a/x11-base/xorg-server/xorg-server-1.17.2-r1.ebuild b/x11-base/xorg-server/xorg-server-1.17.2-r1.ebuild
index d0cb755..6050d63 100644
--- a/x11-base/xorg-server/xorg-server-1.17.2-r1.ebuild
+++ b/x11-base/xorg-server/xorg-server-1.17.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -47,7 +47,7 @@ CDEPEND=">=app-eselect/eselect-opengl-1.3.0
)
drm? ( >=x11-libs/libdrm-2.4.46 )
glamor? (
- media-libs/libepoxy
+ media-libs/libepoxy[X]
>=media-libs/mesa-10.3.4-r1[egl,gbm]
!x11-libs/glamor
)
diff --git a/x11-base/xorg-server/xorg-server-9999.ebuild b/x11-base/xorg-server/xorg-server-9999.ebuild
index e45ef0b..99333cd 100644
--- a/x11-base/xorg-server/xorg-server-9999.ebuild
+++ b/x11-base/xorg-server/xorg-server-9999.ebuild
@@ -6,22 +6,24 @@ EAPI=5
XORG_DOC=doc
inherit xorg-2 multilib versionator flag-o-matic
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/xorg/xserver"
+EGIT_REPO_URI="git://anongit.freedesktop.org/xorg/xserver"
DESCRIPTION="X.Org X servers"
SLOT="0/${PV}"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+KEYWORDS=""
IUSE_SERVERS="dmx kdrive xephyr xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} +drm extra-warn glamor glx ipv6 minimal nptl selinux +suid systemd tslib +udev unwind wayland"
+IUSE="${IUSE_SERVERS} debug glamor ipv6 libressl minimal selinux +suid systemd tslib +udev unwind wayland"
CDEPEND=">=app-eselect/eselect-opengl-1.3.0
- dev-libs/openssl
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
media-libs/freetype
>=x11-apps/iceauth-1.0.2
>=x11-apps/rgb-1.0.3
>=x11-apps/xauth-1.0.3
x11-apps/xkbcomp
+ >=x11-libs/libdrm-2.4.74
>=x11-libs/libpciaccess-0.12.901
>=x11-libs/libXau-1.0.4
>=x11-libs/libXdmcp-1.0.2
@@ -45,7 +47,6 @@ CDEPEND=">=app-eselect/eselect-opengl-1.3.0
>=x11-libs/libXres-1.0.3
>=x11-libs/libXtst-1.0.99.2
)
- drm? ( >=x11-libs/libdrm-2.4.46 )
glamor? (
media-libs/libepoxy
>=media-libs/mesa-10.3.4-r1[egl,gbm]
@@ -66,7 +67,7 @@ CDEPEND=">=app-eselect/eselect-opengl-1.3.0
!minimal? (
>=x11-libs/libX11-1.1.5
>=x11-libs/libXext-1.0.5
- >=media-libs/mesa-10.3.4-r1[nptl=]
+ >=media-libs/mesa-10.3.4-r1
)
tslib? ( >=x11-libs/tslib-1.0 )
udev? ( >=virtual/udev-150 )
@@ -74,6 +75,7 @@ CDEPEND=">=app-eselect/eselect-opengl-1.3.0
wayland? (
>=dev-libs/wayland-1.3.0
media-libs/libepoxy
+ >=dev-libs/wayland-protocols-1.1
)
>=x11-apps/xinit-1.3.3-r1
systemd? (
@@ -89,9 +91,9 @@ DEPEND="${CDEPEND}
>=x11-proto/fixesproto-5.0
>=x11-proto/fontsproto-2.1.3
>=x11-proto/glproto-1.4.17-r1
- >=x11-proto/inputproto-2.2.99.1
+ >=x11-proto/inputproto-2.3
>=x11-proto/kbproto-1.0.3
- >=x11-proto/randrproto-1.4.0
+ >=x11-proto/randrproto-1.5.0
>=x11-proto/recordproto-1.13.99.1
>=x11-proto/renderproto-0.11
>=x11-proto/resourceproto-1.2.0
@@ -104,7 +106,7 @@ DEPEND="${CDEPEND}
>=x11-proto/xf86rushproto-1.1.2
>=x11-proto/xf86vidmodeproto-2.2.99.1
>=x11-proto/xineramaproto-1.1.3
- >=x11-proto/xproto-7.0.26
+ >=x11-proto/xproto-7.0.31
>=x11-proto/presentproto-1.0
>=x11-proto/dri3proto-1.0
dmx? (
@@ -133,7 +135,7 @@ PDEPEND="
REQUIRED_USE="!minimal? (
|| ( ${IUSE_SERVERS} )
)
- xephyr? ( kdrive glx )"
+ xephyr? ( kdrive )"
#UPSTREAMED_PATCHES=(
# "${WORKDIR}/patches/"
@@ -143,9 +145,8 @@ PATCHES=(
"${UPSTREAMED_PATCHES[@]}"
"${FILESDIR}"/${PN}-1.12-unloadsubmodule.patch
# needed for new eselect-opengl, bug #541232
- "${FILESDIR}"/${PN}-1.17-support-multiple-Files-sections.patch
- "${FILESDIR}"/${PN}-fix_stupid_array_bounds_warning.patch
- "${FILESDIR}"/${PN}-fix_declaration_mismatch.patch
+ "${FILESDIR}"/${PN}-1.18-support-multiple-Files-sections.patch
+ "${FILESDIR}"/${PN}-1.18-sysmacros.patch
)
pkg_pretend() {
@@ -166,20 +167,17 @@ src_configure() {
# might still be needed
#use arm && append-cppflags -D__arm32__
- use kdrive && replace-flags "-O3" "-O2"
-
# localstatedir is used for the log location; we need to override the default
# from ebuild.sh
# sysconfdir is used for the xorg.conf location; same applies
- # NOTE: fop is used for doc generating ; and i have no idea if gentoo
+ # NOTE: fop is used for doc generating; and I have no idea if Gentoo
# package it somewhere
XORG_CONFIGURE_OPTIONS=(
$(use_enable ipv6)
+ $(use_enable debug)
$(use_enable dmx)
$(use_enable glamor)
$(use_enable kdrive)
- $(use_enable kdrive kdrive-kbd)
- $(use_enable kdrive kdrive-mouse)
$(use_enable kdrive kdrive-evdev)
$(use_enable suid install-setuid)
$(use_enable tslib)
@@ -187,11 +185,9 @@ src_configure() {
$(use_enable wayland xwayland)
$(use_enable !minimal record)
$(use_enable !minimal xfree86-utils)
- $(use_enable !minimal install-libxf86config)
$(use_enable !minimal dri)
$(use_enable !minimal dri2)
- $(use_enable glx)
- $(use_enable glx aiglx)
+ $(use_enable !minimal glx)
$(use_enable xephyr)
$(use_enable xnest)
$(use_enable xorg)
@@ -201,13 +197,11 @@ src_configure() {
$(use_with doc xmlto)
$(use_with systemd systemd-daemon)
$(use_enable systemd systemd-logind)
- $(use_enable extra-warn selective-werror)
- $(use_enable drm libdrm)
+ --enable-libdrm
--sysconfdir="${EPREFIX}"/etc/X11
--localstatedir="${EPREFIX}"/var
--with-fontrootdir="${EPREFIX}"/usr/share/fonts
--with-xkb-output="${EPREFIX}"/var/lib/xkb
- --disable-xquartz
--disable-config-hal
--disable-linux-acpi
--without-dtrace
@@ -224,7 +218,7 @@ src_install() {
server_based_install
- if ! use minimal && use xorg; then
+ if ! use minimal && use xorg; then
# Install xorg.conf.example into docs
dodoc "${AUTOTOOLS_BUILD_DIR}"/hw/xfree86/xorg.conf.example
fi