summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/xvt/xvt-2.1-r3.ebuild')
-rw-r--r--x11-terms/xvt/xvt-2.1-r3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-terms/xvt/xvt-2.1-r3.ebuild b/x11-terms/xvt/xvt-2.1-r3.ebuild
new file mode 100644
index 000000000000..9979f382b3d5
--- /dev/null
+++ b/x11-terms/xvt/xvt-2.1-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/xvt/xvt-2.1-r3.ebuild,v 1.1 2011/04/18 04:21:09 jer Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A tiny vt100 terminal emulator for X"
+HOMEPAGE="ftp://ftp.x.org/R5contrib/xvt-1.0.README"
+SRC_URI="ftp://ftp.x.org/R5contrib/xvt-1.0.tar.Z
+ mirror://gentoo/xvt-2.1.diff.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+S=${WORKDIR}/${PN}-1.0
+
+src_prepare() {
+ # this brings the distribution upto version 2.1
+ epatch "${WORKDIR}"/${P}.diff
+
+ # fix #61393
+ epatch "${FILESDIR}/${PN}-ttyinit-svr4pty.diff"
+
+ # CFLAGS, CC #241554
+ epatch "${FILESDIR}/${PN}-makefile.patch"
+
+ # int main, not void main
+ epatch "${FILESDIR}/${PN}-int-main.patch"
+
+ # fix segfault (bug #363883)
+ epatch "${FILESDIR}/${PN}-pts.patch"
+
+ tc-export CC
+}
+
+src_install() {
+ dobin xvt || die "dobin failed"
+ doman xvt.1
+ dodoc README
+}