summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/rxvt-unicode/rxvt-unicode-5.3.ebuild')
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-5.3.ebuild106
1 files changed, 0 insertions, 106 deletions
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-5.3.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-5.3.ebuild
deleted file mode 100644
index 7147aaf39f49..000000000000
--- a/x11-terms/rxvt-unicode/rxvt-unicode-5.3.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-5.3.ebuild,v 1.12 2006/02/21 11:03:20 s4t4n Exp $
-
-inherit flag-o-matic
-
-DESCRIPTION="rxvt clone with XFT and Unicode support"
-HOMEPAGE="http://software.schmorp.de/"
-SRC_URI="http://dist.schmorp.de/rxvt-unicode/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ppc ppc64 sparc x86"
-IUSE="xgetdefault tabs"
-
-# see bug #115992 for modular x deps
-RDEPEND="
- || (
- (
- x11-libs/libX11
- x11-libs/libXft
- x11-libs/libXpm
- x11-libs/libXrender
- )
- virtual/x11
- )
- dev-lang/perl
- tabs? ( dev-perl/gtk2-perl )"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- sys-devel/libtool
- || (
- (
- x11-proto/xproto
- x11-libs/libXt
- )
- virtual/x11
- )"
-
-pkg_setup() {
- filter-flags -mno-accumulate-outgoing-args
- replace-flags -Os -O2
-}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- local tdir=/usr/share/terminfo
- sed -i -e \
- "s~@TIC@ \(etc/rxvt\)~@TIC@ -o ${D}/${tdir} \1~" \
- doc/Makefile.in
- sed -i -e \
- "s:-g -O3:${CFLAGS}:" \
- configure
-}
-
-src_compile() {
- econf \
- --enable-everything \
- --enable-rxvt-scroll \
- --enable-next-scroll \
- --enable-xterm-scroll \
- --enable-transparency \
- --enable-xpm-background \
- --enable-fading \
- --enable-utmp \
- --enable-wtmp \
- --enable-mousewheel \
- --enable-slipwheeling \
- --enable-smart-resize \
- --enable-ttygid \
- --enable-256-color \
- --enable-xim \
- --enable-shared \
- --enable-keepscrolling \
- --enable-xft \
- `use_enable xgetdefault` \
- --disable-text-blink \
- --disable-menubar || die
-
- emake || die
-
- if useq tabs ; then
- sed -i \
- -e 's/RXVT_BASENAME = "rxvt"/RXVT_BASENAME = "urxvt"/' \
- ${S}/doc/rxvt-tabbed || die "tabs sed failed"
- fi
-}
-
-src_install() {
- make DESTDIR=${D} install || die
-
- dodoc README.FAQ Changes
- cd ${S}/doc
- dodoc README* changes.txt etc/*
-
- if useq tabs ; then
- newbin rxvt-tabbed urxvt-tabbed
- fi
-}
-
-pkg_postinst() {
- einfo "urxvt now always uses TERM=rxvt-unicode so that the"
- einfo "upstream-supplied terminfo files can be used."
-}