summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/gnome-terminal/gnome-terminal-2.30.2.ebuild')
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-2.30.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-terms/gnome-terminal/gnome-terminal-2.30.2.ebuild b/x11-terms/gnome-terminal/gnome-terminal-2.30.2.ebuild
new file mode 100644
index 000000000000..9b19c3f4f64b
--- /dev/null
+++ b/x11-terms/gnome-terminal/gnome-terminal-2.30.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/gnome-terminal-2.30.2.ebuild,v 1.1 2010/06/22 14:12:20 pacho Exp $
+
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
+
+DESCRIPTION="The Gnome Terminal"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux"
+IUSE=""
+
+# libgnome needed for some monospace font schema, bug #274638
+RDEPEND=">=dev-libs/glib-2.16.0
+ >=x11-libs/gtk+-2.14.0
+ >=gnome-base/gconf-2.14
+ >=x11-libs/vte-0.24.0
+ >=dev-libs/dbus-glib-0.6
+ x11-libs/libSM
+ gnome-base/libgnome"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ >=app-text/gnome-doc-utils-0.3.2
+ >=app-text/scrollkeeper-0.3.11"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Use login shell by default (#12900)
+ epatch "${FILESDIR}"/${PN}-2.22.0-default_shell.patch
+
+ # patch gnome terminal to report as GNOME rather than xterm
+ # This needs to resolve a few bugs (#120294,)
+ # Leave out for now; causing too many problems
+ #epatch ${FILESDIR}/${PN}-2.13.90-TERM-gnome.patch
+}