summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xstroke/xstroke-0.5.12.ebuild')
-rw-r--r--x11-misc/xstroke/xstroke-0.5.12.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/x11-misc/xstroke/xstroke-0.5.12.ebuild b/x11-misc/xstroke/xstroke-0.5.12.ebuild
index 4341afff9388..1e11335eac43 100644
--- a/x11-misc/xstroke/xstroke-0.5.12.ebuild
+++ b/x11-misc/xstroke/xstroke-0.5.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xstroke/xstroke-0.5.12.ebuild,v 1.7 2003/02/11 13:00:40 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xstroke/xstroke-0.5.12.ebuild,v 1.8 2003/02/17 00:32:42 liquidx Exp $
inherit eutils
@@ -9,10 +9,7 @@ IUSE=""
S=${WORKDIR}/${P}
DESCRIPTION="Gesture/Handwriting recognition engine for X"
HOMEPAGE="http://www.east.isi.edu/projects/DSN/xstroke/"
-SRC_URI="ftp://ftp.handhelds.org/pub/projects/${PN}/release-0.5/${P}.tar.gz
- mirror://gentoo/${P}-gentoo.diff.bz2
- http://cvs.gentoo.org/~seemant/${P}-gentoo.diff.bz2"
-
+SRC_URI="ftp://ftp.handhelds.org/pub/projects/${PN}/release-0.5/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 sparc"
@@ -20,13 +17,14 @@ KEYWORDS="x86 sparc"
DEPEND=">=x11-base/xfree-4.1.0"
src_unpack() {
- cd ${WORKDIR}
unpack ${A}
- epatch ${WORKDIR}/${P}-gentoo.diff
+ # generate Makefile from Imakefile
+ cd ${S}; xmkmf -a
}
src_compile() {
- make DESTDIR=${D} || die
+ # otherwise it'll include the wrong freetype headers.
+ make INCLUDES="-I/usr/include/freetype2" || die
}
src_install() {