summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/matchbox-keyboard/matchbox-keyboard-0.1.ebuild')
-rw-r--r--x11-misc/matchbox-keyboard/matchbox-keyboard-0.1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1.ebuild b/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1.ebuild
index 7a46e9100571..bc9f6d953351 100644
--- a/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1.ebuild
+++ b/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 2006-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1.ebuild,v 1.6 2008/07/17 17:15:11 yvasilev Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1.ebuild,v 1.7 2008/08/21 22:38:37 yvasilev Exp $
-inherit versionator
+inherit versionator eutils
DESCRIPTION="Matchbox-keyboard is an on screen 'virtual' or 'software' keyboard."
HOMEPAGE="http://matchbox-project.org/"
@@ -17,6 +17,14 @@ DEPEND="x11-libs/libfakekey
cairo? ( x11-libs/cairo )
!cairo? ( x11-libs/libXft )"
+pkg_setup() {
+ if use cairo && ! built_with_use x11-libs/cairo X ; then
+ eerror "In order to install ${PN} with cairo support you"
+ eerror "need to reinstall x11-libs/cairo with USE='X'."
+ die "x11-libs/cairo built without USE='X'"
+ fi
+}
+
src_compile() {
econf $(use_enable debug) \
$(use_enable cairo) \