summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/alacarte/alacarte-0.13.2.ebuild')
-rw-r--r--x11-misc/alacarte/alacarte-0.13.2.ebuild21
1 files changed, 15 insertions, 6 deletions
diff --git a/x11-misc/alacarte/alacarte-0.13.2.ebuild b/x11-misc/alacarte/alacarte-0.13.2.ebuild
index 237c418068e9..6184f462b1f1 100644
--- a/x11-misc/alacarte/alacarte-0.13.2.ebuild
+++ b/x11-misc/alacarte/alacarte-0.13.2.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/alacarte/alacarte-0.13.2.ebuild,v 1.1 2010/09/16 20:41:29 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/alacarte/alacarte-0.13.2.ebuild,v 1.2 2010/12/08 20:52:52 pacho Exp $
-EAPI="2"
+EAPI="3"
GCONF_DEBUG="no"
+PYTHON_DEPEND="2"
inherit gnome2 python
@@ -15,7 +16,7 @@ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE=""
SLOT=0
-common_depends=">=dev-lang/python-2.4
+common_depends="
>=dev-python/pygobject-2.15.1
>=dev-python/pygtk-2.13
>=gnome-base/gnome-menus-2.27.92[python]"
@@ -28,7 +29,11 @@ DEPEND="${common_depends}
>=dev-util/intltool-0.40.0
>=dev-util/pkgconfig-0.19"
-DOCS="AUTHORS ChangeLog NEWS README"
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ python_set_active_version 2
+ python_pkg_setup
+}
src_prepare() {
gnome2_src_prepare
@@ -38,13 +43,17 @@ src_prepare() {
ln -s $(type -P true) py-compile
}
+src_configure() {
+ PYTHON="$(PYTHON -a)" gnome2_src_configure
+}
+
pkg_postinst() {
gnome2_pkg_postinst
python_need_rebuild
- python_mod_optimize $(python_get_sitedir)/Alacarte
+ python_mod_optimize Alacarte
}
pkg_postrm() {
gnome2_pkg_postrm
- python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/Alacarte
+ python_mod_cleanup Alacarte
}