summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/xosd/xosd-2.2.8.ebuild')
-rw-r--r--x11-libs/xosd/xosd-2.2.8.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-libs/xosd/xosd-2.2.8.ebuild b/x11-libs/xosd/xosd-2.2.8.ebuild
new file mode 100644
index 000000000000..be45729ae379
--- /dev/null
+++ b/x11-libs/xosd/xosd-2.2.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xosd/xosd-2.2.8.ebuild,v 1.1 2004/07/20 17:36:33 lanius Exp $
+
+inherit eutils
+
+IUSE="xinerama xmms"
+
+DESCRIPTION="Library for overlaying text/glyphs in X-Windows X-On-Screen-Display plus binary for sending text from command line"
+HOMEPAGE="http://www.ignavus.net/"
+SRC_URI="http://www.ignavus.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~hppa ~ia64 ~amd64"
+
+DEPEND="virtual/x11
+ xmms? ( media-sound/xmms >=media-libs/gdk-pixbuf-0.22.0 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ local myconf=""
+
+ use xinerama || myconf="${myconf} --disable-xinerama"
+
+ use xmms || myconf="${myconf} --disable-new-plugin"
+
+ econf ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog NEWS COPYING README
+
+ if [ -d ${D}no ]; then
+ rmdir ${D}no
+ fi
+}