summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libxcb')
-rw-r--r--x11-libs/libxcb/ChangeLog11
-rw-r--r--x11-libs/libxcb/libxcb-1.1.90.1.ebuild36
2 files changed, 45 insertions, 2 deletions
diff --git a/x11-libs/libxcb/ChangeLog b/x11-libs/libxcb/ChangeLog
index d7e4838be841..cce77517b26e 100644
--- a/x11-libs/libxcb/ChangeLog
+++ b/x11-libs/libxcb/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/libxcb
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/ChangeLog,v 1.21 2007/11/07 08:40:01 dberkholz Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/ChangeLog,v 1.22 2008/07/30 22:38:05 dberkholz Exp $
+
+*libxcb-1.1.90.1 (30 Jul 2008)
+
+ 30 Jul 2008; Donnie Berkholz <dberkholz@gentoo.org>;
+ +libxcb-1.1.90.1.ebuild:
+ Bump. Adds support for XInput and SELinux extensions, the
+ language-dependent parts of a Python parser, and other bugfixes.
07 Nov 2007; Donnie Berkholz <dberkholz@gentoo.org>; libxcb-1.1.ebuild:
Add a post-installation notice about the new sloppy locking.
diff --git a/x11-libs/libxcb/libxcb-1.1.90.1.ebuild b/x11-libs/libxcb/libxcb-1.1.90.1.ebuild
new file mode 100644
index 000000000000..6854ea9b977a
--- /dev/null
+++ b/x11-libs/libxcb/libxcb-1.1.90.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.1.90.1.ebuild,v 1.1 2008/07/30 22:38:05 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X C-language Bindings library"
+HOMEPAGE="http://xcb.freedesktop.org/"
+SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+LICENSE="X11"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc selinux"
+RDEPEND="x11-libs/libXau
+ x11-libs/libXdmcp
+ dev-libs/libpthread-stubs"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-libs/libxslt
+ >=x11-proto/xcb-proto-1.2"
+
+CONFIGURE_OPTIONS="$(use_enable doc build-docs)
+ $(use_enable selinux xselinux)
+ --enable-xinput"
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ elog "libxcb-1.1 added the LIBXCB_ALLOW_SLOPPY_LOCK variable to allow"
+ elog "broken applications to keep running instead of being aborted."
+ elog "Set this variable if you need to use broken packages such as Java"
+ elog "(for example, add LIBXCB_ALLOW_SLOPPY_LOCK=1 to /etc/env.d/00local"
+ elog "and run env-update)."
+}