summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/gl2ps/files/gl2ps-1.3.5-CMakeLists.patch')
-rw-r--r--x11-libs/gl2ps/files/gl2ps-1.3.5-CMakeLists.patch52
1 files changed, 46 insertions, 6 deletions
diff --git a/x11-libs/gl2ps/files/gl2ps-1.3.5-CMakeLists.patch b/x11-libs/gl2ps/files/gl2ps-1.3.5-CMakeLists.patch
index 3da24a5d1ae3..87e3b7f58172 100644
--- a/x11-libs/gl2ps/files/gl2ps-1.3.5-CMakeLists.patch
+++ b/x11-libs/gl2ps/files/gl2ps-1.3.5-CMakeLists.patch
@@ -1,12 +1,33 @@
-diff -ur gl2ps-1.3.5-source.orig/CMakeLists.txt gl2ps-1.3.5-source/CMakeLists.txt
---- gl2ps-1.3.5-source.orig/CMakeLists.txt 2009-10-16 22:14:07.000000000 +0300
-+++ gl2ps-1.3.5-source/CMakeLists.txt 2010-01-01 12:01:00.000000000 +0200
-@@ -113,21 +113,21 @@
+diff -Nur gl2ps-1.3.5-source.orig/CMakeLists.txt gl2ps-1.3.5-source/CMakeLists.txt
+--- gl2ps-1.3.5-source.orig/CMakeLists.txt 2011-03-16 19:21:58.000000000 +0000
++++ gl2ps-1.3.5-source/CMakeLists.txt 2011-03-16 19:29:50.000000000 +0000
+@@ -46,6 +46,7 @@
+
+ option(ENABLE_ZLIB "Enable compression using ZLIB" ON)
+ option(ENABLE_PNG "Enable PNG support" ON)
++option(ENABLE_DOC "Enable documentation" OFF)
+
+ set(GL2PS_MAJOR_VERSION 1)
+ set(GL2PS_MINOR_VERSION 3)
+@@ -103,39 +104,40 @@
+ include_directories(${EXTERNAL_INCLUDES})
+
+ if(OPENGL_FOUND)
+- add_library(lib STATIC gl2ps.c gl2ps.h)
+- set_target_properties(lib PROPERTIES OUTPUT_NAME gl2ps)
+-
++ #add_library(lib STATIC gl2ps.c gl2ps.h)
+ add_library(shared SHARED gl2ps.c gl2ps.h)
++ set_target_properties(shared PROPERTIES OUTPUT_NAME gl2ps)
++
+ target_link_libraries(shared ${EXTERNAL_LIBRARIES})
+ set_target_properties(shared PROPERTIES OUTPUT_NAME gl2ps)
+ if(MSVC)
set_target_properties(shared PROPERTIES COMPILE_FLAGS "-DGL2PSDLL -DGL2PSDLL_EXPORTS")
endif(MSVC)
- install(TARGETS lib shared DESTINATION lib)
-+ install(TARGETS lib shared DESTINATION lib${LIB_SUFFIX})
++ install(TARGETS shared DESTINATION lib${LIB_SUFFIX})
endif(OPENGL_FOUND)
if(WIN32)
@@ -27,7 +48,18 @@ diff -ur gl2ps-1.3.5-source.orig/CMakeLists.txt gl2ps-1.3.5-source/CMakeLists.tx
if(GLUT_FOUND)
add_executable(gl2psTest WIN32 gl2psTest.c)
-@@ -144,7 +144,6 @@
+- target_link_libraries(gl2psTest lib ${EXTERNAL_LIBRARIES})
++ target_link_libraries(gl2psTest shared ${EXTERNAL_LIBRARIES})
+ add_executable(gl2psTestSimple WIN32 gl2psTestSimple.c)
+- target_link_libraries(gl2psTestSimple lib ${EXTERNAL_LIBRARIES})
++ target_link_libraries(gl2psTestSimple shared ${EXTERNAL_LIBRARIES})
+ endif(GLUT_FOUND)
+
++if(ENABLE_DOC)
+ find_package(LATEX)
+ if(PDFLATEX_COMPILER)
+ add_custom_command(OUTPUT gl2ps.pdf DEPENDS gl2ps.tex
+@@ -144,7 +146,6 @@
COMMAND ${PDFLATEX_COMPILER} ARGS ${CMAKE_SOURCE_DIR}/gl2ps.tex
COMMAND ${CMAKE_COMMAND} -E copy gl2ps.pdf ${CMAKE_SOURCE_DIR})
add_custom_target(pdf ALL DEPENDS gl2ps.pdf)
@@ -35,3 +67,11 @@ diff -ur gl2ps-1.3.5-source.orig/CMakeLists.txt gl2ps-1.3.5-source/CMakeLists.tx
find_program(TTH tth)
if(TTH)
add_custom_command(OUTPUT gl2ps.html DEPENDS gl2ps.tex gl2ps.pdf
+@@ -154,6 +155,7 @@
+ add_custom_target(html DEPENDS gl2ps.html)
+ endif(TTH)
+ endif(PDFLATEX_COMPILER)
++endif(ENABLE_DOC)
+
+ set(CPACK_PACKAGE_VENDOR "Christophe Geuzaine")
+ set(CPACK_PACKAGE_VERSION_MAJOR ${GL2PS_MAJOR_VERSION})