summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-24.0-r1.ebuild')
-rw-r--r--www-client/firefox/firefox-24.0-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/www-client/firefox/firefox-24.0-r1.ebuild b/www-client/firefox/firefox-24.0-r1.ebuild
index 65069978227f..f572683eb0bf 100644
--- a/www-client/firefox/firefox-24.0-r1.ebuild
+++ b/www-client/firefox/firefox-24.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/firefox-24.0-r1.ebuild,v 1.3 2013/09/24 22:42:47 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/firefox-24.0-r1.ebuild,v 1.4 2013/09/26 14:50:18 axs Exp $
EAPI="3"
VIRTUALX_REQUIRED="pgo"
@@ -147,6 +147,8 @@ src_prepare() {
EPATCH_SUFFIX="patch" \
EPATCH_FORCE="yes" \
epatch "${WORKDIR}/firefox"
+ # drop -Wl,--build-id from LDFLAGS, bug #465446
+ epatch "${FILESDIR}"/moz${PV%%\.*}-drop-Wl-build-id.patch
# Allow user to apply any additional patches without modifing ebuild
epatch_user
@@ -157,7 +159,7 @@ src_prepare() {
"${S}"/build/unix/run-mozilla.sh || die "sed failed!"
fi
- # Ensure that are plugins dir is enabled as default
+ # Ensure that our plugins dir is enabled as default
sed -i -e "s:/usr/lib/mozilla/plugins:/usr/lib/nsbrowser/plugins:" \
"${S}"/xpcom/io/nsAppFileLocationProvider.cpp || die "sed failed to replace plugin path for 32bit!"
sed -i -e "s:/usr/lib64/mozilla/plugins:/usr/lib64/nsbrowser/plugins:" \