summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/mythweb/ChangeLog6
-rw-r--r--www-apps/mythweb/Manifest5
-rw-r--r--www-apps/mythweb/files/postinstall-en.txt4
-rw-r--r--www-apps/mythweb/mythweb-0.16.ebuild38
4 files changed, 30 insertions, 23 deletions
diff --git a/www-apps/mythweb/ChangeLog b/www-apps/mythweb/ChangeLog
index 26d760f906a9..85f1b34620b8 100644
--- a/www-apps/mythweb/ChangeLog
+++ b/www-apps/mythweb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apps/mythweb
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.3 2004/09/10 20:47:45 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.4 2004/09/10 23:27:13 aliz Exp $
+
+ 10 Sep 2004; Daniel Ahlberg <aliz@gentoo.org> mythweb-0.16.ebuild:
+ + Webapp-config support, closing #58382.
+ + Added checks and warning about php5.
*mythweb-0.16 (10 Sep 2004)
diff --git a/www-apps/mythweb/Manifest b/www-apps/mythweb/Manifest
index f5a3faeb2f6e..4541e31aae05 100644
--- a/www-apps/mythweb/Manifest
+++ b/www-apps/mythweb/Manifest
@@ -1,9 +1,10 @@
MD5 f3a22688a66e69c9cc5598d8f57981d3 mythweb-0.15.1.ebuild 1175
MD5 8c7186a3b2b63e1a10a72654ccb5a7dc mythweb-0.14-r1.ebuild 1149
MD5 7908f91d928964e412a3f27ba210842e mythweb-0.14.ebuild 1018
-MD5 1de164fcc2ae6a2c52e1d82357191dee ChangeLog 2516
+MD5 b58c27a2ab8e323022bc3e592e490f25 ChangeLog 2670
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
-MD5 761902b9135154634381b36d3b566753 mythweb-0.16.ebuild 1115
+MD5 77f72782b103d0a7fd721f1d60f2ee1b mythweb-0.16.ebuild 1124
+MD5 9801c208655265155f568ca06ca43b28 files/postinstall-en.txt 175
MD5 7ed0401bccae5ab3c413c6463fae929f files/digest-mythweb-0.14 65
MD5 5395065f53f0a626950525982e828830 files/digest-mythweb-0.16 65
MD5 7ed0401bccae5ab3c413c6463fae929f files/digest-mythweb-0.14-r1 65
diff --git a/www-apps/mythweb/files/postinstall-en.txt b/www-apps/mythweb/files/postinstall-en.txt
new file mode 100644
index 000000000000..a0ab6b6526b7
--- /dev/null
+++ b/www-apps/mythweb/files/postinstall-en.txt
@@ -0,0 +1,4 @@
+You should modify ${MY_INSTALLDIR}/config/conf.php to fit your needs.
+
+If you are using php5 you may experience bugs, please report these to
+either Gentoo or MythTV bugzilla.
diff --git a/www-apps/mythweb/mythweb-0.16.ebuild b/www-apps/mythweb/mythweb-0.16.ebuild
index 2c6b6d32a626..ae8be9a40657 100644
--- a/www-apps/mythweb/mythweb-0.16.ebuild
+++ b/www-apps/mythweb/mythweb-0.16.ebuild
@@ -1,42 +1,40 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.16.ebuild,v 1.1 2004/09/10 20:47:45 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.16.ebuild,v 1.2 2004/09/10 23:27:13 aliz Exp $
-inherit webapp-apache
+inherit webapp
DESCRIPTION="PHP scripts intended to manage MythTV from a web browser."
HOMEPAGE="http://www.mythtv.org/"
SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
IUSE=""
LICENSE="GPL-2"
-SLOT="0"
KEYWORDS="~x86 ~amd64"
RDEPEND=">=dev-php/mod_php-4.2"
pkg_setup() {
- webapp-detect || NO_WEBSERVER=1
- einfo "Installing ${PN} into ${HTTPD_ROOT}"
+ if has_version \>=dev-php/mod_php-5 ; then
+ local modphp_use="$(</var/db/pkg/`best_version =dev-php/mod_php`/USE)"
+ if ! has session ${modphp_use} ; then
+ eerror "mod_php is missing session support. Please add"
+ eerror "'session' to your USE flags, and re-emerge mod_php and php."
+ die "mod_php needs session support"
+ fi
+ fi
+
+ webapp_pkg_setup
}
src_install() {
- webapp-mkdirs
+ webapp_src_preinst
- dodoc README TODO ; rm -f README TODO
+ dodoc README TODO
- dodir "${HTTPD_ROOT}"
- cp -R "${S}" "${D}${HTTPD_ROOT}/${PN}"
+ cp -R [[:lower:]]* ${D}/${MY_HTDOCSDIR}
- keepdir "${HTTPD_ROOT}/${PN}/"{php_sessions,image_cache}
- fowners "${HTTPD_USER}:${HTTPD_GROUP}" "${HTTPD_ROOT}/${PN}/"{php_sessions,image_cache}
+ webapp_configfile ${MY_HTDOCSDIR}/config/conf.php
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
- # protect configfiles
- echo "CONFIG_PROTECT=${HTTPD_ROOT}/${PN}/config" > ${T}/27mythweb
- insinto /etc/env.d ; doins ${T}/27mythweb
-}
-
-pkg_postinst() {
- einfo "You should modify ${HTTPD_ROOT}/${PN}/config/conf.php"
- einfo "to fit your needs."
- echo
+ webapp_src_install
}