summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/jekyll-paginate/jekyll-paginate-1.0.0.ebuild')
-rw-r--r--www-apps/jekyll-paginate/jekyll-paginate-1.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/www-apps/jekyll-paginate/jekyll-paginate-1.0.0.ebuild b/www-apps/jekyll-paginate/jekyll-paginate-1.0.0.ebuild
new file mode 100644
index 000000000000..7a2177bb3e34
--- /dev/null
+++ b/www-apps/jekyll-paginate/jekyll-paginate-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/jekyll-paginate/jekyll-paginate-1.0.0.ebuild,v 1.1 2014/08/15 14:52:22 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Default pagination generator for Jekyll"
+HOMEPAGE="https://github.com/jekyll/jekyll-paginate"
+SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=www-apps/jekyll-2 )"
+
+all_ruby_prepare() {
+ rm Rakefile || die
+}