summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/watchpid/watchpid-0.1-r1.ebuild')
-rw-r--r--sys-process/watchpid/watchpid-0.1-r1.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/sys-process/watchpid/watchpid-0.1-r1.ebuild b/sys-process/watchpid/watchpid-0.1-r1.ebuild
index a6ca6b3b85a4..6d2fe08ccaa3 100644
--- a/sys-process/watchpid/watchpid-0.1-r1.ebuild
+++ b/sys-process/watchpid/watchpid-0.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/watchpid/watchpid-0.1-r1.ebuild,v 1.1 2005/03/03 16:20:18 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/watchpid/watchpid-0.1-r1.ebuild,v 1.2 2006/04/30 17:34:22 swegener Exp $
DESCRIPTION="Watches a process for termination"
-SRC_URI="http://www.codepark.org/projects/utils/${PN}_${PV}.tar.gz"
+SRC_URI="mirror://gentoo/${PN}_${PV}.tar.gz"
HOMEPAGE="http://www.codepark.org/"
KEYWORDS="x86 amd64 -ppc"
IUSE=""
@@ -12,12 +12,11 @@ LICENSE="GPL-2"
DEPEND="virtual/libc"
src_compile() {
- ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} || die
- make ${MAKEOPTS} || die
+ econf || die "econf failed"
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
- cd ${S}
- dodoc README AUTHORS COPYING NEWS
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc README AUTHORS
}