summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/readline/ChangeLog8
-rw-r--r--sys-libs/readline/Manifest11
-rw-r--r--sys-libs/readline/files/readline-5.1-rlfe-libutil.patch66
-rw-r--r--sys-libs/readline/readline-5.1-r2.ebuild3
4 files changed, 80 insertions, 8 deletions
diff --git a/sys-libs/readline/ChangeLog b/sys-libs/readline/ChangeLog
index bf0528c6d8b4..a09b540c346c 100644
--- a/sys-libs/readline/ChangeLog
+++ b/sys-libs/readline/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/readline
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.58 2005/12/27 04:55:15 kanaka Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.59 2006/01/05 11:20:30 flameeyes Exp $
+
+ 05 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/readline-5.1-rlfe-libutil.patch, readline-5.1-r2.ebuild:
+ Add patch to complete rlfe linking when openpty() is in libutil.
27 Dec 2005; Joel Martin <kanaka@gentoo.org> readline-5.1-r2.ebuild:
Cross-compile fix was partially backed out, put it back in.
diff --git a/sys-libs/readline/Manifest b/sys-libs/readline/Manifest
index 13d19e61eb72..1be58318b41a 100644
--- a/sys-libs/readline/Manifest
+++ b/sys-libs/readline/Manifest
@@ -1,7 +1,7 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 700594fb255dc5da5014fdaa385a5b6f ChangeLog 8748
+MD5 339cd3c0304426278f5d21a10d0ca619 ChangeLog 8938
MD5 d687545889dacb43e121f4932d99a534 files/bash-3.0-etc-inputrc.patch 1443
MD5 cca21eb56279efff8356d028b1b39dd8 files/digest-readline-4.3-r5 348
MD5 cca21eb56279efff8356d028b1b39dd8 files/digest-readline-4.3-r6 348
@@ -16,16 +16,17 @@ MD5 a0bad5c8ba91f5c50ea6c2c97a76f2d1 files/readline-5.0-self-insert.patch 2463
MD5 fe45d673627dab53fb3fcffcb4f55e4e files/readline-5.0-solaris.patch 756
MD5 e4ac33c0a2293b72378e00e8729c71af files/readline-5.1-cleanups.patch 3817
MD5 73869a19bab0f37a7ee46e377d2bac15 files/readline-5.1-rlfe-build.patch 252
+MD5 d5beb2bc88ccec6e3344a6094004e4bc files/readline-5.1-rlfe-libutil.patch 3056
MD5 acf485e32b4ff28ae6aec238c3a4581c files/readline-5.1-rlfe-uclibc.patch 308
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 f57994b50a6ef31969945eef6dfa6a80 readline-4.3-r5.ebuild 2765
MD5 6af52eb762dd5c0220974c9c853181c2 readline-4.3-r6.ebuild 3091
MD5 5c962060bc5f3a5bb5935407f4fdf1a8 readline-5.0-r2.ebuild 2781
-MD5 328392b6dbdd45107aac5c12048f7d7f readline-5.1-r2.ebuild 3015
+MD5 21c45284ab57e8c8b764e376fa19f880 readline-5.1-r2.ebuild 3064
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDuhsj2+ySkm8kpY0RAsczAJwLDplIE70IFIw8YZK6wVgEzEAMygCghxSK
-mCwRXa4kidvxkgHdDdlDzNc=
-=bc7L
+iD8DBQFDvQEKAiZjviIA2XgRApSaAKCM59HLqu+SeYNvdNwWc3/sA9TSxgCgy1oG
+UIefKvWEsHb1gS+dQV+Ccxk=
+=hX6f
-----END PGP SIGNATURE-----
diff --git a/sys-libs/readline/files/readline-5.1-rlfe-libutil.patch b/sys-libs/readline/files/readline-5.1-rlfe-libutil.patch
new file mode 100644
index 000000000000..14a1a155c1b9
--- /dev/null
+++ b/sys-libs/readline/files/readline-5.1-rlfe-libutil.patch
@@ -0,0 +1,66 @@
+On FreeBSD the openpty() function is provided by libutil. For this rason, it
+has to be linked in the final executable. The current test is broken because
+it sets LIBS but that variable never gets into the Makefile. To make simpler
+its handling, just set a LIBUTIL variable that would be empty where it's not
+needed and contains -lutil where needed.
+
+Index: readline-5.1/examples/rlfe/Makefile.in
+===================================================================
+--- readline-5.1.orig/examples/rlfe/Makefile.in
++++ readline-5.1/examples/rlfe/Makefile.in
+@@ -25,7 +25,7 @@ CFLAGS = @CFLAGS@
+ CPPFLAGS = @CPPFLAGS@
+ #LDFLAGS = -L$(READLINE_DIR)
+ LDFLAGS = @LDFLAGS@ -L../..
+-LIBS = -lreadline -lhistory -lncurses
++LIBS = -lreadline -lhistory -lncurses @LIBUTIL@
+
+ CPP=@CPP@
+ CPP_DEPEND=$(CC) -MM
+Index: readline-5.1/examples/rlfe/configure.in
+===================================================================
+--- readline-5.1.orig/examples/rlfe/configure.in
++++ readline-5.1/examples/rlfe/configure.in
+@@ -251,9 +251,11 @@ AC_CHECK_FUNCS(getpt)
+ dnl check for openpty()
+ if test -z "$sysvr4ptys"; then
+ AC_CHECK_FUNCS(openpty,,
+-[AC_CHECK_LIB(util,openpty, [AC_DEFINE(HAVE_OPENPTY)] [LIBS="$LIBS -lutil"])])
++[AC_CHECK_LIB(util,openpty, [AC_DEFINE(HAVE_OPENPTY)] [LIBUTIL="-lutil"])])
+ fi
+
++AC_SUBST(LIBUTIL)
++
+ AC_CHECKING(for ptyranges)
+ if test -d /dev/ptym ; then
+ pdir='/dev/ptym'
+Index: readline-5.1/examples/rlfe/configure
+===================================================================
+--- readline-5.1.orig/examples/rlfe/configure
++++ readline-5.1/examples/rlfe/configure
+@@ -272,7 +272,7 @@ PACKAGE_STRING=
+ PACKAGE_BUGREPORT=
+
+ ac_unique_file="rlfe.c"
+-ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS VERSION CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT CPP EGREP AWK WRITEPATH XTERMPATH LIBOBJS LTLIBOBJS'
++ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS VERSION CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT CPP EGREP AWK LIBUTIL WRITEPATH XTERMPATH LIBOBJS LTLIBOBJS'
+ ac_subst_files=''
+
+ # Initialize some variables set by options.
+@@ -3805,7 +3805,7 @@ if test $ac_cv_lib_util_openpty = yes; t
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_OPENPTY 1
+ _ACEOF
+- LIBS="$LIBS -lutil"
++ LIBUTIL="-lutil"
+ fi
+
+ fi
+@@ -4908,6 +4908,7 @@ s,@OBJEXT@,$OBJEXT,;t t
+ s,@CPP@,$CPP,;t t
+ s,@EGREP@,$EGREP,;t t
+ s,@AWK@,$AWK,;t t
++s,@LIBUTIL@,$LIBUTIL,;t t
+ s,@WRITEPATH@,$WRITEPATH,;t t
+ s,@XTERMPATH@,$XTERMPATH,;t t
+ s,@LIBOBJS@,$LIBOBJS,;t t
diff --git a/sys-libs/readline/readline-5.1-r2.ebuild b/sys-libs/readline/readline-5.1-r2.ebuild
index 2a3a928d611f..809f5cf01f72 100644
--- a/sys-libs/readline/readline-5.1-r2.ebuild
+++ b/sys-libs/readline/readline-5.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-5.1-r2.ebuild,v 1.7 2006/01/03 06:34:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-5.1-r2.ebuild,v 1.8 2006/01/05 11:20:30 flameeyes Exp $
inherit eutils multilib toolchain-funcs
@@ -43,6 +43,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-cleanups.patch
epatch "${FILESDIR}"/${P}-rlfe-build.patch #116483
epatch "${FILESDIR}"/${P}-rlfe-uclibc.patch
+ epatch "${FILESDIR}/${P}-rlfe-libutil.patch"
ln -s ../.. examples/rlfe/readline