summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/slang/slang-1.4.9-r1.ebuild')
-rw-r--r--sys-libs/slang/slang-1.4.9-r1.ebuild30
1 files changed, 14 insertions, 16 deletions
diff --git a/sys-libs/slang/slang-1.4.9-r1.ebuild b/sys-libs/slang/slang-1.4.9-r1.ebuild
index f2f0c0ff2989..a486fd3fff3d 100644
--- a/sys-libs/slang/slang-1.4.9-r1.ebuild
+++ b/sys-libs/slang/slang-1.4.9-r1.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-1.4.9-r1.ebuild,v 1.13 2004/11/02 14:50:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-1.4.9-r1.ebuild,v 1.14 2004/11/05 01:44:52 vapier Exp $
-inherit gcc eutils
+inherit eutils
-DESCRIPTION="Console display library used by most text viewer"
-HOMEPAGE="http://space.mit.edu/~davis/slang/"
# Patches are taken from http://www.suse.de/~nadvornik/slang/
# They were originally Red Hat and Debian's patches
+
+DESCRIPTION="Console display library used by most text viewer"
+HOMEPAGE="http://space.mit.edu/~davis/slang/"
SRC_URI="ftp://space.mit.edu/pub/davis/slang/v1.4/${P}.tar.bz2"
LICENSE="GPL-2 | Artistic"
@@ -21,31 +22,29 @@ src_unpack() {
unpack ${P}.tar.bz2
cd ${S}
- epatch ${FILESDIR}/${P}.dif
- epatch ${FILESDIR}/${P}-fsuid.dif
- epatch ${FILESDIR}/${P}-autoconf.dif
+ epatch ${FILESDIR}/${P}.patch
+ epatch ${FILESDIR}/${P}-fsuid.patch
+ epatch ${FILESDIR}/${P}-autoconf.patch
if use unicode ; then
epatch ${FILESDIR}/slang-debian-utf8.patch
epatch ${FILESDIR}/slang-utf8-acs.patch
epatch ${FILESDIR}/slang-utf8-fix.patch
fi
if use cjk ; then
- # enable Kanji Support
- cp src/sl-feat.h src/sl-feat.h.bak
- sed "/SLANG_HAS_KANJI_SUPPORT/s/0/1/" \
- src/sl-feat.h.bak > src/sl-feat.h
+ sed -i \
+ -e "/SLANG_HAS_KANJI_SUPPORT/s/0/1/" \
+ src/sl-feat.h
fi
}
src_compile() {
econf || die "econf failed"
- # emake doesn't work well with slang, so just use normal make.
- make all elf || die "make failed"
+ emake -j1 all elf || die "make failed"
}
src_install() {
make install install-elf DESTDIR=${D} || die "make install failed"
- use ppc-macos || fperms 755 /usr/$(get_libdir)/libslang.so.*
+ chmod "${D}"/usr/$(get_libdir)/libslang.so.*
if use unicode ; then
for i in ${D}/usr/$(get_libdir)/libslang-utf8* ; do
@@ -55,9 +54,8 @@ src_install() {
dosym /usr/$(get_libdir)/libslang{-utf8,}.a
fi
- # remove the documentation... we want to install it ourselves
rm -rf ${D}/usr/doc
- dodoc COPYING* NEWS README *.txt
+ dodoc NEWS README *.txt
dodoc doc/*.txt doc/internal/*.txt doc/text/*.txt
dohtml doc/*.html
}