summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/s3ql/s3ql-1.12.ebuild')
-rw-r--r--sys-fs/s3ql/s3ql-1.12.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/sys-fs/s3ql/s3ql-1.12.ebuild b/sys-fs/s3ql/s3ql-1.12.ebuild
deleted file mode 100644
index f53dab0d446a..000000000000
--- a/sys-fs/s3ql/s3ql-1.12.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/s3ql/s3ql-1.12.ebuild,v 1.3 2013/01/07 08:54:18 mgorny Exp $
-
-EAPI="4"
-
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_SRC_TEST="setup.py"
-
-inherit distutils
-
-DESCRIPTION="A full-featured file system for online data storage"
-HOMEPAGE="http://code.google.com/p/s3ql/"
-SRC_URI="http://s3ql.googlecode.com/files/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="contrib doc test"
-
-RDEPEND="dev-python/setuptools
- >=dev-python/apsw-3.7.0
- >=dev-python/llfuse-0.37
- dev-python/pycryptopp
- dev-python/pyliblzma
- sys-fs/fuse
- virtual/python-argparse"
-DEPEND="${RDEPEND}
- test? (
- net-misc/rsync[xattr]
- virtual/python-unittest2
- )"
-
-src_test() {
- if [[ ${EUID} -ne 0 ]] ; then
- ewarn "Skipping tests: root privileges are required so userpriv must be disabled"
- else
- addwrite /dev/fuse
- distutils_src_test
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use contrib ; then
- exeinto /usr/share/doc/${PF}/contrib
- docompress -x /usr/share/doc/${PF}/contrib
- doexe contrib/*.{py,sh}
- doman contrib/*.1
- fi
-
- if use doc ; then
- dodoc doc/manual.pdf
- dohtml -r doc/html/*
- fi
-}