summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-freebsd/freebsd-lib/freebsd-lib-6.1.ebuild')
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-6.1.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-6.1.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-6.1.ebuild
index ca24f17f3226..5d11a3215366 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-6.1.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-6.1.ebuild,v 1.10 2006/09/03 11:25:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-6.1.ebuild,v 1.11 2006/10/05 20:57:29 flameeyes Exp $
inherit bsdmk freebsd flag-o-matic toolchain-funcs
@@ -8,7 +8,7 @@ DESCRIPTION="FreeBSD's base system libraries"
SLOT="6.0"
KEYWORDS="~x86-fbsd"
-IUSE="atm bluetooth ssl ipv6 kerberos nis gpib"
+IUSE="atm bluetooth ssl ipv6 kerberos nis gpib build"
# Crypto is needed to have an internal OpenSSL header
# sys is needed for libalias, probably we can just extract that instead of
@@ -21,6 +21,8 @@ SRC_URI="mirror://gentoo/${LIB}.tar.bz2
mirror://gentoo/${INCLUDE}.tar.bz2
nis? ( mirror://gentoo/${USBIN}.tar.bz2 )
!kernel_FreeBSD? (
+ mirror://gentoo/${SYS}.tar.bz2 )
+ build? (
mirror://gentoo/${SYS}.tar.bz2 )"
if [[ ${CATEGORY/cross-} == ${CATEGORY} ]]; then
@@ -102,6 +104,10 @@ REMOVE_SUBDIRS="libncurses libform libmenu libpanel \
src_unpack() {
freebsd_src_unpack
+ sed -i -e 's:-o/dev/stdout:-t:' ${S}/libc/net/Makefile.inc
+
+ use build && return 0
+
if [[ ${CTARGET} == ${CHOST} ]]; then
ln -s "/usr/src/sys-${RV}" "${WORKDIR}/sys"
else
@@ -111,8 +117,6 @@ src_unpack() {
[[ -n $(install --version 2> /dev/null | grep GNU) ]] && \
sed -i -e 's:${INSTALL} -C:${INSTALL}:' "${WORKDIR}/include/Makefile"
-
- sed -i -e 's:-o/dev/stdout:-t:' ${S}/libc/net/Makefile.inc
}
src_compile() {